summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-22 21:44:37 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-22 21:44:37 +0000
commit1976da129a39fc10ae81acaaba0c0ce1b402f7e6 (patch)
treeaac5ca375286823ce7debf3efa1be446fa97b771 /app-emulation
parentVersion bumped. Closes 39025 (Manifest recommit) (diff)
downloadgentoo-2-1976da129a39fc10ae81acaaba0c0ce1b402f7e6.tar.gz
gentoo-2-1976da129a39fc10ae81acaaba0c0ce1b402f7e6.tar.bz2
gentoo-2-1976da129a39fc10ae81acaaba0c0ce1b402f7e6.zip
cleanup
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/digest-wine-200310164
-rw-r--r--app-emulation/wine/wine-20031016.ebuild127
2 files changed, 0 insertions, 131 deletions
diff --git a/app-emulation/wine/files/digest-wine-20031016 b/app-emulation/wine/files/digest-wine-20031016
deleted file mode 100644
index 7ab8a9fa52aa..000000000000
--- a/app-emulation/wine/files/digest-wine-20031016
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 67eed2fb7a86d805ec8fc4bcf7a04254 Wine-20031016.tar.gz 9452596
-MD5 fa4393cbc288ea89f761ad8d9258cc68 wine-20031016-xopenfont.patch 833
-MD5 af8da46a0e51578ff1e18e399141d628 wine-20031016-fake_windows.tar.bz2 500
-MD5 b629202e9983e301daca512f01ddbbb0 wine-20031016-misc.tar.bz2 4925
diff --git a/app-emulation/wine/wine-20031016.ebuild b/app-emulation/wine/wine-20031016.ebuild
deleted file mode 100644
index 4c7e27b17e6e..000000000000
--- a/app-emulation/wine/wine-20031016.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20031016.ebuild,v 1.3 2003/12/10 20:06:32 mholzer Exp $
-
-inherit eutils base
-
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
-HOMEPAGE="http://www.winehq.com/"
-SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
- mirror://gentoo/${P}-xopenfont.patch
- mirror://gentoo/${P}-fake_windows.tar.bz2
- mirror://gentoo/${P}-misc.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -ppc -sparc"
-IUSE="nas arts cups opengl alsa tcltk nptl debug"
-
-DEPEND="sys-devel/gcc
- sys-devel/flex
- dev-util/yacc
- >=sys-libs/ncurses-5.2
- >=media-libs/freetype-2.0.0
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tcl dev-lang/tk )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )"
-
-src_unpack() {
- base_src_unpack
- cd ${S}
- epatch ${DISTDIR}/${P}-xopenfont.patch
- epatch ${FILESDIR}/${PN}-alsa.patch
-}
-
-src_compile() {
- # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
-
- unset CFLAGS CXXFLAGS
-
- ac_cv_header_jack_jack_h=no \
- ac_cv_lib_soname_jack= \
- ./configure \
- --prefix=/usr/lib/wine \
- --sysconfdir=/etc/wine \
- --host=${CHOST} \
- --enable-curses \
- `use_enable opengl` \
- `use_with nptl` \
- `use_enable debug trace` \
- `use_enable debug` \
- || die "configure failed"
-
- cd ${S}/programs/winetest
- sed -i 's:wine.pm:include/wine.pm:' Makefile
-
- # No parallel make
- cd ${S}
- make depend all || die
- cd programs && emake || die
-}
-
-src_install() {
- local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
-
- ### Install wine to ${D}
- make ${WINEMAKEOPTS} install || die
- cd ${S}/programs
- make ${WINEMAKEOPTS} install || die
-
- # Needed for later installation
- dodir /usr/bin
-
- ### Creation of /usr/lib/wine/.data
- # Setting up fake_windows
- dodir /usr/lib/wine/.data
- cd ${D}/usr/lib/wine/.data
- tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
- chown root:root fake_windows/ -R
-
- # Unpacking the miscellaneous files
- tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
- chown root:root config
-
- # moving the wrappers to bin/
- insinto /usr/bin
- dobin regedit-wine wine
- rm regedit-wine wine
-
- # copying the winedefault.reg into .data
- insinto /usr/lib/wine/.data
- doins ${WORKDIR}/${P}/winedefault.reg
-
- # Set up this dynamic data
- cd ${S}
- insinto /usr/lib/wine/.data/fake_windows/Windows
- doins documentation/samples/system.ini
- doins documentation/samples/generic.ppd
- ## Setup of .data complete
-
- ### Misc tasks
- # Take care of the documentation
- cd ${S}
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
-
- # Manpage setup
- cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
- rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
- rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
-
- # Remove the executable flag from those libraries.
- cd ${D}/usr/lib/wine/lib/wine
- chmod a-x *.so
-}
-
-pkg_postinst() {
- einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
- einfo "which will take care of everything else."
- einfo ""
- einfo "Use /usr/bin/regedit-wine to import registry files into the"
- einfo "wine registry."
-}