summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-12 08:24:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-12 08:24:44 +0000
commit1b7dd20aead9dcbcb11c4d702ac0cff2a88dfb7e (patch)
treeb44bd67c331a9f40ba1fafe8b086f10f90228dca /app-emulation
parentDependencie updates (diff)
downloadgentoo-2-1b7dd20aead9dcbcb11c4d702ac0cff2a88dfb7e.tar.gz
gentoo-2-1b7dd20aead9dcbcb11c4d702ac0cff2a88dfb7e.tar.bz2
gentoo-2-1b7dd20aead9dcbcb11c4d702ac0cff2a88dfb7e.zip
FHS2.1 fixes and dependencie updates.
This package is untested. I only made sure it compiles and installes correct.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/digest-wine-200103261
-rw-r--r--app-emulation/wine/wine-20010326.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/wine/files/digest-wine-20010326 b/app-emulation/wine/files/digest-wine-20010326
new file mode 100644
index 000000000000..73c7c562fcea
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20010326
@@ -0,0 +1 @@
+MD5 2b8037c1aee32de2e725907901a6f3b2 Wine-20010326.tar.gz
diff --git a/app-emulation/wine/wine-20010326.ebuild b/app-emulation/wine/wine-20010326.ebuild
new file mode 100644
index 000000000000..b81039d782a6
--- /dev/null
+++ b/app-emulation/wine/wine-20010326.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20010326.ebuild,v 1.1 2001/04/12 08:24:44 achim Exp $
+
+A=Wine-${PV}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/${A}"
+HOMEPAGE="http://www.winehq.com"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-libs/ncurses-5.2
+ opengl? ( media-libs/mesa-glue )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use opengl`" ]
+ then
+ myconf="--enable-opengl"
+ else
+ myconf="--disable-opengl"
+ fi
+ try ./configure --prefix=/usr --libdir=/usr/lib/wine --sysconfdir=/etc/wine \
+ --host=${CHOST} ${myconf}
+
+ try make depend
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr libdir=${D}/usr/lib/wine mandir=${D}/usr/share/man install
+ insinto /etc/wine
+ doins ${FILESDIR}/wine.conf
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE
+ dodoc README WARRANTY
+
+}
+