summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-08-09 17:35:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-08-09 17:35:54 +0000
commit31836986c8b3573bdf43a501a35dbce9f803b876 (patch)
tree3a113ae5abb36d6c451cc708daca4420d2ea049c /app-emulation
parent[app-emulation/xen-tools] Sync 9999 and 4.1.1 (diff)
downloadgentoo-2-31836986c8b3573bdf43a501a35dbce9f803b876.tar.gz
gentoo-2-31836986c8b3573bdf43a501a35dbce9f803b876.tar.bz2
gentoo-2-31836986c8b3573bdf43a501a35dbce9f803b876.zip
[app-emulation/xen-pvgrub] Version bump and fix bug #362689
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-pvgrub/ChangeLog8
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild4
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-4.1.1.ebuild97
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild9
4 files changed, 108 insertions, 10 deletions
diff --git a/app-emulation/xen-pvgrub/ChangeLog b/app-emulation/xen-pvgrub/ChangeLog
index 8f52fcd54d36..de207d74d23f 100644
--- a/app-emulation/xen-pvgrub/ChangeLog
+++ b/app-emulation/xen-pvgrub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen-pvgrub
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.2 2011/05/12 13:55:40 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.3 2011/08/09 17:35:54 alexxy Exp $
+
+*xen-pvgrub-4.1.1 (09 Aug 2011)
+
+ 09 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-pvgrub-4.1.0.ebuild,
+ +xen-pvgrub-4.1.1.ebuild, xen-pvgrub-9999.ebuild:
+ Version bump and fix bug #362689
12 May 2011; Jeremy Olexa <darkside@gentoo.org> xen-pvgrub-4.1.0.ebuild,
xen-pvgrub-9999.ebuild:
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild
index bdb4396dbacc..de7ab4fe9b8e 100644
--- a/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild,v 1.2 2011/05/12 13:55:40 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.0.ebuild,v 1.3 2011/08/09 17:35:54 alexxy Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="
http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz
http://alpha.gnu.org/gnu/grub/grub-0.97.tar.gz
http://downloads.sourceforge.net/project/libpng/zlib/1.2.3/zlib-1.2.3.tar.gz
- ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/pciutils-2.2.9.tar.gz
+ http://www.kernel.org/pub/software/utils/pciutils/pciutils-2.2.9.tar.bz2
http://download.savannah.gnu.org/releases/lwip/lwip-1.3.0.tar.gz
ftp://sources.redhat.com/pub/newlib/newlib-1.16.0.tar.gz
"
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1.ebuild
new file mode 100644
index 000000000000..396e12af00a0
--- /dev/null
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1.ebuild,v 1.1 2011/08/09 17:35:54 alexxy Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="allows to boot Xen domU kernels from a menu.lst laying inside guest filesystem"
+HOMEPAGE="http://xen.org/"
+SRC_URI="
+ http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz
+ http://alpha.gnu.org/gnu/grub/grub-0.97.tar.gz
+ http://downloads.sourceforge.net/project/libpng/zlib/1.2.3/zlib-1.2.3.tar.gz
+ http://www.kernel.org/pub/software/utils/pciutils/pciutils-2.2.9.tar.bz2
+ http://download.savannah.gnu.org/releases/lwip/lwip-1.3.0.tar.gz
+ ftp://sources.redhat.com/pub/newlib/newlib-1.16.0.tar.gz
+ "
+
+S="${WORKDIR}/xen-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom-cflags"
+
+DEPEND="sys-devel/gettext
+ sys-devel/gcc"
+
+RDEPEND=">=app-emulation/xen-${PV}"
+
+src_prepare() {
+ # Drop .config
+ sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+
+ sed -i \
+ -e 's/WGET=.*/WGET=cp -t . /' \
+ -e "s;\$(XEN_EXTFILES_URL);${DISTDIR};" \
+ -e 's/$(LD)/$(LD) LDFLAGS=/' \
+ -e 's;install-grub: pv-grub;install-grub:;' \
+ "${S}"/stubdom/Makefile || die
+ # Fix gcc-4.6
+ sed -i \
+ -e "s:-Werror::g" \
+ -i tools/libxc/Makefile \
+ -i extras/mini-os/minios.mk || die
+}
+
+src_compile() {
+ use custom-cflags || unset CFLAGS
+ if test-flag-CC -fno-strict-overflow; then
+ append-flags -fno-strict-overflow
+ fi
+
+ emake -C tools/include || die "prepare libelf headers failed"
+
+ if use x86; then
+ emake XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || die "compile pv-grub_x86_32 failed"
+ fi
+ if use amd64; then
+ emake XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub || die "compile pv-grub_x86_64 failed"
+ if use multilib; then
+ multilib_toolchain_setup x86
+ emake XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || die "compile pv-grub_x86_32 failed"
+ fi
+ fi
+}
+
+src_install() {
+ if use x86; then
+ emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom install-grub || die "install pv-grub_x86_32 failed"
+ fi
+ if use amd64; then
+ emake XEN_TARGET_ARCH="x86_64" DESTDIR="${D}" -C stubdom install-grub || die "install pv-grub_x86_64 failed"
+ if use multilib; then
+ emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom install-grub || die "install pv-grub_x86_32 failed"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://en.gentoo-wiki.com/wiki/Xen/"
+}
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild
index e1c1a3e359b7..7a725b17473d 100644
--- a/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild,v 1.2 2011/05/12 13:55:40 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-9999.ebuild,v 1.3 2011/08/09 17:35:54 alexxy Exp $
EAPI="2"
@@ -11,7 +11,7 @@ HOMEPAGE="http://xen.org/"
SRC_URI="
http://alpha.gnu.org/gnu/grub/grub-0.97.tar.gz
http://downloads.sourceforge.net/project/libpng/zlib/1.2.3/zlib-1.2.3.tar.gz
- ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/pciutils-2.2.9.tar.gz
+ http://www.kernel.org/pub/software/utils/pciutils/pciutils-2.2.9.tar.bz2
http://download.savannah.gnu.org/releases/lwip/lwip-1.3.0.tar.gz
ftp://sources.redhat.com/pub/newlib/newlib-1.16.0.tar.gz
"
@@ -75,11 +75,6 @@ src_prepare() {
-e 's/$(LD)/$(LD) LDFLAGS=/' \
-e 's;install-grub: pv-grub;install-grub:;' \
"${S}"/stubdom/Makefile || die
- # Fix gcc-4.6
- sed -i \
- -e "s:-Werror::g" \
- -i tools/libxc/Makefile \
- -i extras/mini-os/minios.mk || die
}
src_compile() {