summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-04-10 18:04:18 +0000
committerTilman Klar <phoenix@gentoo.org>2003-04-10 18:04:18 +0000
commit3cb8ae30a724ca75dd7c1a3b8419fbc3730a91ee (patch)
tree8674b6c8933c8914624278a7e43b818f1d9418ee /app-emulation
parentInitial commit (diff)
downloadgentoo-2-3cb8ae30a724ca75dd7c1a3b8419fbc3730a91ee.tar.gz
gentoo-2-3cb8ae30a724ca75dd7c1a3b8419fbc3730a91ee.tar.bz2
gentoo-2-3cb8ae30a724ca75dd7c1a3b8419fbc3730a91ee.zip
Version bump.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/files/digest-wine-200304081
-rw-r--r--app-emulation/wine/files/wine-20030408-fake_windows.tar.bz2bin0 -> 500 bytes
-rw-r--r--app-emulation/wine/files/wine-20030408-misc.tar.bz2bin0 -> 4591 bytes
-rw-r--r--app-emulation/wine/files/wine-20030408-xopenfont.patch45
-rw-r--r--app-emulation/wine/wine-20030408.ebuild126
6 files changed, 179 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index e4d2d92144d3..f04a732f2099 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.32 2003/04/06 16:01:13 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.33 2003/04/10 18:03:45 phoenix Exp $
+
+*wine-20030318 (10 Apr 2003)
+
+ 10 Apr 2003; Tilman Klar <phoenix@gentoo.org> wine-20030318.ebuild,
+ files/digest-wine-20030318 :
+ Version bump. This should fix the glibc-2.3.2 problems.
*wine-20030318 (06 Apr 2003)
diff --git a/app-emulation/wine/files/digest-wine-20030408 b/app-emulation/wine/files/digest-wine-20030408
new file mode 100644
index 000000000000..a64bb9872f6f
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030408
@@ -0,0 +1 @@
+MD5 8c578d05d60ef627e7f2959c220f3056 Wine-20030408.tar.gz 8521264
diff --git a/app-emulation/wine/files/wine-20030408-fake_windows.tar.bz2 b/app-emulation/wine/files/wine-20030408-fake_windows.tar.bz2
new file mode 100644
index 000000000000..d60f11e08ee3
--- /dev/null
+++ b/app-emulation/wine/files/wine-20030408-fake_windows.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20030408-misc.tar.bz2 b/app-emulation/wine/files/wine-20030408-misc.tar.bz2
new file mode 100644
index 000000000000..90b963f8896c
--- /dev/null
+++ b/app-emulation/wine/files/wine-20030408-misc.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20030408-xopenfont.patch b/app-emulation/wine/files/wine-20030408-xopenfont.patch
new file mode 100644
index 000000000000..7f83e11ba4e9
--- /dev/null
+++ b/app-emulation/wine/files/wine-20030408-xopenfont.patch
@@ -0,0 +1,45 @@
+--- graphics/x11drv/xfont.c.orig 2003-04-06 18:27:44.000000000 +0200
++++ graphics/x11drv/xfont.c 2003-04-06 18:27:58.000000000 +0200
+@@ -2115,7 +2115,7 @@
+ }
+ else lpstr = x_pattern[i];
+
+- if( (x_fs = TSXLoadQueryFont(gdi_display, lpstr)) )
++ if( (x_fs = XFONT_GetFont(lpstr)) )
+ {
+ XFONT_SetFontMetric( fi, fr, x_fs );
+ TSXFreeFont( gdi_display, x_fs );
+@@ -3239,6 +3239,33 @@
+ return NULL;
+ }
+
++static int staticXError;
++
++static int fonterror_handler(Display *display,
++ XErrorEvent *error_evt)
++{
++ ERR("X error %d\n", error_evt->error_code);
++ return 0;
++}
++
++static XFontStruct * XFONT_GetFont(char *lpstr)
++{
++ XFontStruct* x_fs;
++ void *ptr;
++
++ wine_tsx11_lock();
++ staticXError = FALSE;
++ ptr = XSetErrorHandler(fonterror_handler);
++ x_fs = XLoadQueryFont(gdi_display, lpstr);
++ XSync(gdi_display, False);
++ XSetErrorHandler(ptr);
++ wine_tsx11_unlock();
++ if (staticXError)
++ return NULL;
++ else
++ return x_fs;
++}
++
+
+
+ /* X11DRV Interface ****************************************************
diff --git a/app-emulation/wine/wine-20030408.ebuild b/app-emulation/wine/wine-20030408.ebuild
new file mode 100644
index 000000000000..1fea79ba80dc
--- /dev/null
+++ b/app-emulation/wine/wine-20030408.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030408.ebuild,v 1.1 2003/04/10 18:03:45 phoenix Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl
+ dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ epatch ${FILESDIR}/${P}-xopenfont.patch
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # use the default setting in ./configure over the /etc/make.conf setting
+ unset CFLAGS CXXFLAGS
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${FILESDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+ einfo "If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+}