summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-05-28 15:49:07 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-05-28 15:49:07 +0000
commit42a0664ce430b150049405747f971169f77c7485 (patch)
treee492b2f135a480873666c785fc17193092649c61 /app-emulation
parentstable x86, bug 260125 (diff)
downloadgentoo-2-42a0664ce430b150049405747f971169f77c7485.tar.gz
gentoo-2-42a0664ce430b150049405747f971169f77c7485.tar.bz2
gentoo-2-42a0664ce430b150049405747f971169f77c7485.zip
Bump to kvm-kmod-86
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog8
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-86.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index ce8cc5aebb70..b8be4da77268 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.1 2009/04/28 01:45:38 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.2 2009/05/28 15:49:07 dang Exp $
+
+*kvm-kmod-86 (28 May 2009)
+
+ 28 May 2009; Daniel Gryniewicz <dang@gentoo.org> +kvm-kmod-86.ebuild:
+ Bump to kvm-kmod-86
+
*kvm-kmod-85 (28 Apr 2009)
diff --git a/app-emulation/kvm-kmod/kvm-kmod-86.ebuild b/app-emulation/kvm-kmod/kvm-kmod-86.ebuild
new file mode 100644
index 000000000000..72f0671fadcf
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-86.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-86.ebuild,v 1.1 2009/05/28 15:49:07 dang Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+MY_PN="${PN}-devel"
+MY_P="${MY_PN}-${PV}"
+
+# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
+PATCHSET="kvm-patches-20090218"
+SRC_URI="mirror://sourceforge/kvm/${MY_P}.tar.gz"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ !<app-emulation/kvm-85"
+
+S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kvm:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kvm:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kvm:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}