summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-12-14 17:50:21 +0000
committerPeter Volkov <pva@gentoo.org>2006-12-14 17:50:21 +0000
commit60f7e5f2a9a476ecddc57437b5f3dffad076f7fd (patch)
treeb357d28bbf4d52fa378acca09567dcdb556a109f /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-60f7e5f2a9a476ecddc57437b5f3dffad076f7fd.tar.gz
gentoo-2-60f7e5f2a9a476ecddc57437b5f3dffad076f7fd.tar.bz2
gentoo-2-60f7e5f2a9a476ecddc57437b5f3dffad076f7fd.zip
Bumping version in hope that somebody take a look at this package and attach patches at b.g.o. Cleaning out old versions.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uae/ChangeLog13
-rw-r--r--app-emulation/uae/files/digest-uae-0.8.253
-rw-r--r--app-emulation/uae/uae-0.8.25.ebuild78
3 files changed, 92 insertions, 2 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index dcb3551e5391..cd8c7a802cb2 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/uae
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.26 2005/09/16 21:12:33 ciaranm Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.27 2006/12/14 17:50:21 pva Exp $
+
+*uae-0.8.25 (14 Dec 2006)
+
+ 14 Dec 2006; Peter Volkov <pva@gentoo.org>
+ -files/uae-0.8.22-alsa-support.diff, -files/uae-patch.diff,
+ -uae-0.8.22.ebuild, -uae-0.8.22-r1.ebuild, -uae-0.8.24.ebuild,
+ +uae-0.8.25.ebuild:
+ Bumping version in hope that somebody take a look at this package and attach
+ patches at b.g.o. Cleaning out old versions.
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/app-emulation/uae/files/digest-uae-0.8.25 b/app-emulation/uae/files/digest-uae-0.8.25
new file mode 100644
index 000000000000..1c1390f95d26
--- /dev/null
+++ b/app-emulation/uae/files/digest-uae-0.8.25
@@ -0,0 +1,3 @@
+MD5 e660ca2bec3c016c978ef88117b0c432 uae-0.8.25.tar.gz 970727
+RMD160 6990dc7aaf43c8bda0d7b86e6d0ae164209d1eb1 uae-0.8.25.tar.gz 970727
+SHA256 611a7e04dd77080d87c7e9680aed997ed2be45116eec91613eb36a85235a686a uae-0.8.25.tar.gz 970727
diff --git a/app-emulation/uae/uae-0.8.25.ebuild b/app-emulation/uae/uae-0.8.25.ebuild
new file mode 100644
index 000000000000..33fc5bc2fa39
--- /dev/null
+++ b/app-emulation/uae/uae-0.8.25.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25.ebuild,v 1.1 2006/12/14 17:50:21 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="The Umiquious Amiga Emulator"
+HOMEPAGE="http://www.freiburg.linux.de/~uae/"
+SRC_URI="ftp://ftp.freiburg.linux.de/pub/uae/sources/develop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="sdl X dga svga ncurses alsa sdl-sound scsi gtk"
+
+DEPEND="sdl? ( media-libs/libsdl )
+ !sdl? ( X? ( x11-libs/libXext
+ x11-libs/libXxf86vm
+ dga? ( x11-libs/libXxf86dga ) )
+ !X? ( svga? ( media-libs/svgalib )
+ !svga? ( ncurses? ( sys-libs/ncurses )
+ !ncurses? ( media-libs/libsdl ) ) ) )
+ alsa? ( media-libs/libsdl )
+ !alsa? ( sdl-sound? ( media-libs/alsa-lib ) )
+ scsi? ( app-cdr/cdrtools )
+ gtk? ( x11-libs/gtk+ )"
+
+pkg_setup() {
+ if use sdl ; then
+ elog "Enabling sdl for video output."
+ my_config="$(use_with sdl) $(use_with sdl sdl-gfx)"
+ elif use X ; then
+ elog "Enabling X11 for video output."
+ my_config="$(use_with X x) $(use_enable X vidmode)"
+ use dga? && my_config="${my_config} $(use_enable dga)"
+ elif use svga? ; then
+ elog "Enabling svga for video output."
+ my_config="$(use_with svga svgalib)"
+ elif use ncurses? ; then
+ elog "Enabling ncurses for video output."
+ my_config="$(use_with ncurses asciiart)"
+ else
+ ewarn "You have not enabled sdl or X or svga or ncruses in USE!"
+ ewarn "Video output is not selected. Falling back on sdl..."
+ my_config="$(use_with sdl) $(use_with sdl sdl-gfx)"
+ fi
+
+ if use alsa ; then
+ elog "Enabling alsa for sound output."
+ my_config="${my_config} $(use_with alsa)"
+ elif use sdl-sound ; then
+ elog "Enabling sdl for sound output."
+ my_config="${my_config} $(use_with sdl sdl-sound)"
+ else
+ elog "You have not enabled sdl-sound and alsa in USE!"
+ elog "Using sound output to file."
+ my_config="${my_config} --enable-file-sound"
+ fi
+
+ use gtk && my_config="${my_config} --enable-ui"
+ use scsi && my_config="${my_config} --enable-scsi-device"
+ my_config="${my_config} --enable-threads"
+}
+
+
+src_compile() {
+ econf ${my_config} || die "configure failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin uae readdisk || die
+ cp docs/unix/README docs/README.unix
+ dodoc docs/*
+
+ insinto /usr/share/uae/amiga-tools
+ doins amiga/{*hack,trans*,uae*}
+}