summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-12 19:29:10 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-12 19:29:10 +0000
commit6a783eaa95a4cc85a9edb03254ae739b41809fca (patch)
tree1a9519cdb552c6c2ceb55968ab8f851d4bb97f63 /app-emulation
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6a783eaa95a4cc85a9edb03254ae739b41809fca.tar.gz
gentoo-2-6a783eaa95a4cc85a9edb03254ae739b41809fca.tar.bz2
gentoo-2-6a783eaa95a4cc85a9edb03254ae739b41809fca.zip
Version bump to 0.9
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ChangeLog10
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild35
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ChangeLog b/app-emulation/ganeti-instance-debootstrap/ChangeLog
index 0fce7bdf55d5..e21a5d06ecd0 100644
--- a/app-emulation/ganeti-instance-debootstrap/ChangeLog
+++ b/app-emulation/ganeti-instance-debootstrap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/ganeti-instance-debootstrap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.2 2010/03/07 21:03:00 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.3 2010/03/12 19:29:10 ramereth Exp $
+
+*ganeti-instance-debootstrap-0.9 (12 Mar 2010)
+
+ 12 Mar 2010; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-instance-debootstrap-0.9.ebuild:
+ Version bump to 0.9
+
+ * Install example hooks
*ganeti-instance-debootstrap-0.8 (07 Mar 2010)
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
new file mode 100644
index 000000000000..1b3f680d3965
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild,v 1.1 2010/03/12 19:29:10 ramereth Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}