summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-10 05:06:04 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-10 05:06:04 +0000
commit79ea3cd0c00509abe124a7aba2dea884508e6780 (patch)
treeccd8e30f540c8d998a21caedd3bdc1875422a755 /app-emulation
parentWhitespace (diff)
downloadgentoo-2-79ea3cd0c00509abe124a7aba2dea884508e6780.tar.gz
gentoo-2-79ea3cd0c00509abe124a7aba2dea884508e6780.tar.bz2
gentoo-2-79ea3cd0c00509abe124a7aba2dea884508e6780.zip
Fix up kernel features required for LXC.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog6
-rw-r--r--app-emulation/libvirt/libvirt-1.0.3-r2.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-1.0.4.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-1.0.5.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild7
5 files changed, 21 insertions, 13 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index e4f4fa225bf4..247c534567b7 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.263 2013/05/06 14:51:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.264 2013/05/10 05:06:04 cardoe Exp $
+
+ 10 May 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.0.3-r2.ebuild,
+ libvirt-1.0.4.ebuild, libvirt-1.0.5.ebuild, libvirt-9999.ebuild:
+ Fix up kernel features required for LXC.
*libvirt-1.0.5 (06 May 2013)
diff --git a/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild b/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
index d06bb73c8ad0..4df99b4888f9 100644
--- a/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild,v 1.2 2013/03/20 19:10:06 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild,v 1.3 2013/05/10 05:06:04 cardoe Exp $
EAPI=5
@@ -161,8 +161,9 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
- kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR" || \
- LXC_CONFIG_CHECK+=" ~MEMCG"
+ kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
diff --git a/app-emulation/libvirt/libvirt-1.0.4.ebuild b/app-emulation/libvirt/libvirt-1.0.4.ebuild
index f1de9e9a1f83..69876b2ba0b6 100644
--- a/app-emulation/libvirt/libvirt-1.0.4.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.4.ebuild,v 1.1 2013/04/04 18:14:18 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.4.ebuild,v 1.2 2013/05/10 05:06:04 cardoe Exp $
EAPI=5
@@ -161,8 +161,9 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
- kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR" || \
- LXC_CONFIG_CHECK+=" ~MEMCG"
+ kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
diff --git a/app-emulation/libvirt/libvirt-1.0.5.ebuild b/app-emulation/libvirt/libvirt-1.0.5.ebuild
index cdbaf1e8089a..964ec3ff2a41 100644
--- a/app-emulation/libvirt/libvirt-1.0.5.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.ebuild,v 1.1 2013/05/06 14:51:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.ebuild,v 1.2 2013/05/10 05:06:04 cardoe Exp $
EAPI=5
@@ -161,8 +161,9 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
- kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR" || \
- LXC_CONFIG_CHECK+=" ~MEMCG"
+ kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index b6b84c6222de..c83f7a9cd908 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.45 2013/03/23 20:30:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.46 2013/05/10 05:06:04 cardoe Exp $
EAPI=5
@@ -161,8 +161,9 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
- kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR" || \
- LXC_CONFIG_CHECK+=" ~MEMCG"
+ kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
use fuse && CONFIG_CHECK+=" ~FUSE_FS"