summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-01 15:31:53 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-01 15:31:53 +0000
commit8f9fbcbf2ff2992df5a47d53b0bca95bc4b02fca (patch)
tree6fd10326bf0984334faecc60d6987d34a78a2548 /app-emulation
parentStable for x86, wrt bug #483204 (diff)
downloadgentoo-2-8f9fbcbf2ff2992df5a47d53b0bca95bc4b02fca.tar.gz
gentoo-2-8f9fbcbf2ff2992df5a47d53b0bca95bc4b02fca.tar.bz2
gentoo-2-8f9fbcbf2ff2992df5a47d53b0bca95bc4b02fca.zip
Fix USE=custom-cflags build with -O3 and recent gcc versions (bug #480508, thanks to Konstantin).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/wine-1.6-memset-O3.patch21
-rw-r--r--app-emulation/wine/wine-1.6.ebuild3
-rw-r--r--app-emulation/wine/wine-1.7.0.ebuild3
-rw-r--r--app-emulation/wine/wine-9999.ebuild3
5 files changed, 33 insertions, 4 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 4f51efc770c3..2e2236729b54 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.475 2013/09/01 14:38:32 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.476 2013/09/01 15:31:53 tetromino Exp $
+
+ 01 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.6.ebuild,
+ wine-1.7.0.ebuild, wine-9999.ebuild, +files/wine-1.6-memset-O3.patch:
+ Fix USE=custom-cflags build with -O3 and recent gcc versions (bug #480508,
+ thanks to Konstantin).
01 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.2.3.ebuild,
wine-1.3.28.ebuild, wine-1.4.ebuild, wine-1.4.1.ebuild, wine-1.5.0.ebuild,
diff --git a/app-emulation/wine/files/wine-1.6-memset-O3.patch b/app-emulation/wine/files/wine-1.6-memset-O3.patch
new file mode 100644
index 000000000000..75372f869141
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.6-memset-O3.patch
@@ -0,0 +1,21 @@
+Avoid "undefined reference to `memset'" error when building with
+USE=custom-cflags and -O3 in CFLAGS with gcc-4.8.
+
+See:
+
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56888
+http://bugs.winehq.org/show_bug.cgi?id=33521
+https://bugs.gentoo.org/show_bug.cgi?id=480508
+
+diff --git a/configure.ac b/configure.ac
+index d8033cf..fe7cc7d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1767,6 +1767,7 @@ then
+
+ dnl Check for some compiler flags
+ WINE_TRY_CFLAGS([-fno-builtin],[AC_SUBST(BUILTINFLAG,"-fno-builtin")])
++ WINE_TRY_CFLAGS([-fno-tree-loop-distribute-patterns])
+ WINE_TRY_CFLAGS([-fno-strict-aliasing])
+ dnl clang needs to be told to fail on unknown options
+ saved_CFLAGS=$CFLAGS
diff --git a/app-emulation/wine/wine-1.6.ebuild b/app-emulation/wine/wine-1.6.ebuild
index 089f5b7a5482..f08acbd76a43 100644
--- a/app-emulation/wine/wine-1.6.ebuild
+++ b/app-emulation/wine/wine-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.ebuild,v 1.4 2013/09/01 14:38:32 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.ebuild,v 1.5 2013/09/01 15:31:53 tetromino Exp $
EAPI="5"
@@ -177,6 +177,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.5.26-winegcc.patch #260726
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
+ "${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
[[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
diff --git a/app-emulation/wine/wine-1.7.0.ebuild b/app-emulation/wine/wine-1.7.0.ebuild
index be0f1883fb64..d2194789db68 100644
--- a/app-emulation/wine/wine-1.7.0.ebuild
+++ b/app-emulation/wine/wine-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.0.ebuild,v 1.3 2013/09/01 14:38:32 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.0.ebuild,v 1.4 2013/09/01 15:31:53 tetromino Exp $
EAPI="5"
@@ -177,6 +177,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.5.26-winegcc.patch #260726
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
+ "${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
[[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 1a4cb2263047..0adf7cad59ce 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.150 2013/09/01 14:38:32 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.151 2013/09/01 15:31:53 tetromino Exp $
EAPI="5"
@@ -177,6 +177,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.5.26-winegcc.patch #260726
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
+ "${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
[[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365