summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-22 05:28:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-22 05:28:26 +0000
commitb3fbefa7850302d4c2abf7c17ee7c74c1130398b (patch)
treeb4d15835202004a70298d4239d947fd3aa101c95 /app-emulation
parentmozilla-1.5 fix (diff)
downloadgentoo-2-b3fbefa7850302d4c2abf7c17ee7c74c1130398b.tar.gz
gentoo-2-b3fbefa7850302d4c2abf7c17ee7c74c1130398b.tar.bz2
gentoo-2-b3fbefa7850302d4c2abf7c17ee7c74c1130398b.zip
inherit eutils for epatch; more error checking/messages
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/Manifest4
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild28
3 files changed, 22 insertions, 15 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 6b93af02a69a..0e31a48c0f56 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.14 2003/10/01 11:41:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.15 2003/11/22 05:28:24 mr_bones_ Exp $
+
+ 21 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> bochs-2.0.2.ebuild:
+ inherit eutils for epatch; more error checking/messages
29 Sep 2003; Martin Holzer <mholzer@gentoo.org> bochs-2.0.2.ebuild,
files/bochs-2.0.2-gcc3.patch:
diff --git a/app-emulation/bochs/Manifest b/app-emulation/bochs/Manifest
index fd77580e96b3..9aebfde4c687 100644
--- a/app-emulation/bochs/Manifest
+++ b/app-emulation/bochs/Manifest
@@ -1,7 +1,7 @@
-MD5 4815a1fea5c2bdcbf940b5db84670ce1 ChangeLog 1379
+MD5 876e49f5ce7c643e357dc7af206cddc6 ChangeLog 1518
MD5 3fc3de44c4d8ea336e2e8c3e65984593 bochs-1.4.1.ebuild 1589
MD5 887420e60dbb71b6c6736f5e170e4484 bochs-1.4.ebuild 1519
-MD5 141c15f6a0753097f8df88806312a481 bochs-2.0.2.ebuild 1593
+MD5 3a27ab07bdbaac95ec7bad8be9a11749 bochs-2.0.2.ebuild 1518
MD5 44d0eed7e91d9d7e3306a87383b76bba bochs-2.0.ebuild 1492
MD5 98e5b3f35a6f0ad02450764b07b344f6 files/digest-bochs-1.4 124
MD5 45eecf87d56bd4562cffd0c8cfe666f9 files/digest-bochs-1.4.1 126
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index e516472fda30..aafc98f89e59 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.7 2003/11/12 14:15:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.8 2003/11/22 05:28:24 mr_bones_ Exp $
+
+inherit eutils
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -23,10 +25,10 @@ src_unpack() {
cd ${S}
sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
- die "sed Makefile.in failed"
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
+ die "sed Makefile.in failed"
epatch ${FILESDIR}/${P}-gcc3.patch || die
}
@@ -35,15 +37,17 @@ src_compile() {
myconf="${myconf} `use_with sdl`"
myconf="${myconf} `use_with gtk wx`"
- ./configure --enable-fpu --enable-cdrom --enable-control-panel \
- --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
- --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
- --with-x11 $myconf || die "configure failed"
+ ./configure \
+ --enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
+ --with-x11 $myconf || \
+ die "configure failed"
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc CHANGES CVS README TESTFORM.txt || die "dodoc failed"
}