summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-09-05 21:27:08 +0000
committerHanno Böck <hanno@gentoo.org>2006-09-05 21:27:08 +0000
commitb427ed5208d112ad36bf4510edfb6549f1977508 (patch)
tree5923eb7f4a28b273c95863e995fa632ab92639a6 /app-emulation
parentA graphical interface for modifying the system language (diff)
downloadgentoo-2-b427ed5208d112ad36bf4510edfb6549f1977508.tar.gz
gentoo-2-b427ed5208d112ad36bf4510edfb6549f1977508.tar.bz2
gentoo-2-b427ed5208d112ad36bf4510edfb6549f1977508.zip
dosemu 1.3.3 bump
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/ChangeLog8
-rw-r--r--app-emulation/dosemu/dosemu-1.3.3.ebuild73
-rw-r--r--app-emulation/dosemu/files/digest-dosemu-1.3.36
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch87
4 files changed, 173 insertions, 1 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index b961c82ef542..d73b58ed6803 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.33 2006/07/28 15:08:09 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.34 2006/09/05 21:27:08 hanno Exp $
+
+*dosemu-1.3.3 (05 Sep 2006)
+
+ 05 Sep 2006; Hanno Boeck <hanno@gentoo.org>
+ +files/dosemu-1.3.3-configure.ac.patch, +dosemu-1.3.3.ebuild:
+ Version bump.
28 Jul 2006; Hanno Boeck <hanno@gentoo.org> dosemu-1.2.2-r1.ebuild,
dosemu-1.3.2.ebuild:
diff --git a/app-emulation/dosemu/dosemu-1.3.3.ebuild b/app-emulation/dosemu/dosemu-1.3.3.ebuild
new file mode 100644
index 000000000000..63f9cca15b7f
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.3.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.3.ebuild,v 1.1 2006/09/05 21:27:08 hanno Exp $
+
+inherit flag-o-matic eutils autotools
+
+P_FD=dosemu-freedos-b9r5a-bin
+DESCRIPTION="DOS Emulator"
+HOMEPAGE="http://www.dosemu.org/"
+SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
+ mirror://sourceforge/dosemu/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X svga gpm debug"
+
+RDEPEND="X? (
+ || ( (
+ x11-libs/libXxf86vm
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-proto/xf86dgaproto
+ x11-apps/xset
+ x11-apps/xlsfonts
+ )
+ virtual/x11
+ ) )
+ svga? ( media-libs/svgalib )
+ gpm? ( sys-libs/gpm )
+ =sys-libs/slang-1.4*"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.57"
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-configure.ac.patch
+
+ eautoreconf || die "autoconf failed"
+}
+
+src_compile() {
+ # Has problems with -O3 on some systems
+ replace-flags -O[3-9] -O2
+
+ # Fix compilation on hardened
+ append-flags -fno-pic
+
+ unset KERNEL
+
+ use X || myflags="--with-x=no"
+
+ ./default-configure ${myflags} \
+ `use_enable svga svgalib` \
+ `use_enable debug` \
+ `use_with gpm` \
+ --with-fdtarball=${DISTDIR}/${P_FD}.tgz \
+ --sysconfdir=/etc/dosemu/ \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/app-emulation/dosemu/files/digest-dosemu-1.3.3 b/app-emulation/dosemu/files/digest-dosemu-1.3.3
new file mode 100644
index 000000000000..7e4ba4fed1f7
--- /dev/null
+++ b/app-emulation/dosemu/files/digest-dosemu-1.3.3
@@ -0,0 +1,6 @@
+MD5 f3b27a9326e5c95e59093fcb79a61023 dosemu-1.3.3.tgz 2118984
+RMD160 6afa11d3c10173134ed6cc9485ac05495dd65188 dosemu-1.3.3.tgz 2118984
+SHA256 710adaf9d7e6b3e25ceb180d84056d76fb65d5215897ada04ca6a629b5518c2d dosemu-1.3.3.tgz 2118984
+MD5 153ef4f6ab653497836502c9e3e18c3a dosemu-freedos-b9r5a-bin.tgz 1154735
+RMD160 54b2c7c2ca13139b555f6c0318576b9db91875da dosemu-freedos-b9r5a-bin.tgz 1154735
+SHA256 bd143b04add270425f117c5186468914765437c7b9c9c9a44eb0f278798e6850 dosemu-freedos-b9r5a-bin.tgz 1154735
diff --git a/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch b/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch
new file mode 100644
index 000000000000..51dfe03202af
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch
@@ -0,0 +1,87 @@
+--- dosemu-old/configure.ac 2005-12-21 20:47:43.000000000 -0500
++++ dosemu-1.3.3/configure.ac 2006-02-23 15:07:06.000000000 -0500
+@@ -15,7 +15,6 @@
+ AC_CANONICAL_TARGET([])
+
+ dnl Checks for programs.
+-OPT=$CFLAGS
+ AC_PROG_CC
+ if test "$host_cpu" = "x86_64" -a -z "$CPPFLAGS"; then
+ # 64bit long mode dosemu is not yet
+@@ -478,19 +477,6 @@
+ INCDIR="-I\${top_builddir}/src/include -I\${top_builddir}/src/plugin/include"
+ AC_SUBST(INCDIR)
+
+-CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs"
+-if test -z "$OPT"; then
+- if test "$enable_debug" = "yes"; then
+- CFLAGS="$CFLAGS -g"
+- AC_DEFINE(_DEBUG)
+- OPT="-O"
+- else
+- OPT="-O2" # BIG NOTE: do _not_ use -O3,
+- # because in forces _inline_ at places where we don't want it !
+- # If we want _inline_, well then we 'code' it.
+- OPT="$OPT -fomit-frame-pointer" # never omit the frame pointer when debugging!
+- fi
+-fi
+ if test "$enable_debug" = "yes"; then
+ AC_DEFINE(_DEBUG)
+ fi
+@@ -540,7 +526,6 @@
+ AC_MSG_NOTICE(Compiling with network support...);
+ AC_DEFINE(USING_NET)
+ fi
+- PIPE=-pipe
+ fi
+
+
+@@ -590,39 +575,6 @@
+ fi
+
+
+- # -m486 is usually in the specs for the compiler
+- # but gcc-3.0 wants -mcpu=i486 instead
+- # and gcc-3.4 wants -mtune=i486 instead
+- # let the compiler options be dependent of the _target_
+- # where dosemu is compiled for, not the host
+- if test "$target_cpu" = "athlon" -a $GCC_VERSION_CODE -le 2095 ; then
+- target_cpu="i686"
+- fi
+- if test "$target_cpu" = "x86_64"; then
+- target_cpu="k8"
+- fi
+- if test "$GCC_VERSION_CODE" -ge 3004 ; then
+- OPT="$OPT -mtune=$target_cpu"
+- elif test "$GCC_VERSION_CODE" -ge 2095 ; then
+- OPT="$OPT -mcpu=$target_cpu"
+- else
+- case "$target_cpu" in
+- i486)
+- OPT="$OPT -m486"
+- ;;
+- i386)
+- OPT="$OPT -m386"
+- ;;
+- *)
+- ;;
+- esac
+- fi
+- if test "$target_cpu" = "athlon"; then
+- OPT="$OPT -malign-functions=4 -fexpensive-optimizations"
+- elif test "$target_cpu" = "i486"; then
+- OPT="$OPT -malign-loops=2 -malign-jumps=2 -malign-functions=2"
+- fi
+-
+ AC_MSG_CHECKING(for glibc...)
+ set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
+ major=$1; minor=$2
+@@ -643,7 +595,7 @@
+ AC_SUBST(ASM_PEDANTIC)
+ AC_DEFINE(_GNU_SOURCE)
+
+-CFLAGS="${CFLAGS} ${OPT} ${PIPE}"
++CFLAGS=${OPT}
+ CPPFLAGS="${CPPFLAGS} -MMD"
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(LIBS)