summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-03-29 10:46:51 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-03-29 10:46:51 +0000
commitbaa0a8b79c9af34cb98949d69119a78301622f22 (patch)
treecb59de62362bd914c88ea7d25c533be2e4eb185a /app-emulation
parentreadd libdir fix and clean out old releases (diff)
downloadgentoo-2-baa0a8b79c9af34cb98949d69119a78301622f22.tar.gz
gentoo-2-baa0a8b79c9af34cb98949d69119a78301622f22.tar.bz2
gentoo-2-baa0a8b79c9af34cb98949d69119a78301622f22.zip
New version
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kqemu/ChangeLog7
-rw-r--r--app-emulation/kqemu/files/digest-kqemu-1.3.0_pre53
-rw-r--r--app-emulation/kqemu/kqemu-1.3.0_pre5.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index 66664a2d3150..cba178ec7d43 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kqemu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.4 2006/03/29 08:02:54 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.5 2006/03/29 10:46:51 lu_zero Exp $
+
+*kqemu-1.3.0_pre5 (29 Mar 2006)
+
+ 29 Mar 2006; Luca Barbato <lu_zero@gentoo.org> +kqemu-1.3.0_pre5.ebuild:
+ New kqemu, thanks to Sven <skoehler@upb.de>
29 Mar 2006; Chris White <chriswhite@gentoo.org> kqemu-0.7.2.ebuild:
x86 stable for kqemu-0.7.2 bug #123972.
diff --git a/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre5 b/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre5
new file mode 100644
index 000000000000..5d4bfd84dfa9
--- /dev/null
+++ b/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre5
@@ -0,0 +1,3 @@
+MD5 2dc13fa4645a8d7c69f0f42aabf64cf5 kqemu-1.3.0pre5.tar.gz 189395
+RMD160 cc54ac38791f543feb91285292ecf7ca333d9918 kqemu-1.3.0pre5.tar.gz 189395
+SHA256 2f2983393a4e007741685ef4e889fc91fe7619a038fc43998d414e441f5813a7 kqemu-1.3.0pre5.tar.gz 189395
diff --git a/app-emulation/kqemu/kqemu-1.3.0_pre5.ebuild b/app-emulation/kqemu/kqemu-1.3.0_pre5.ebuild
new file mode 100644
index 000000000000..89cd0767425d
--- /dev/null
+++ b/app-emulation/kqemu/kqemu-1.3.0_pre5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre5.ebuild,v 1.1 2006/03/29 10:46:51 lu_zero Exp $
+
+inherit eutils flag-o-matic linux-mod toolchain-funcs
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator kernel fast execution module"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${MY_P}.tar.gz"
+
+LICENSE="KQEMU"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE=""
+
+S="${WORKDIR}/$MY_P"
+
+DEPEND=""
+
+pkg_setup() {
+ MODULE_NAMES="kqemu(misc:${S})"
+ linux-mod_pkg_setup
+
+ einfo "kqemu is binary module with a restricted license."
+ einfo "Please read carefully the KQEMU license"
+ einfo "and ${HOMEPAGE}qemu-accel.html"
+ einfo "if you would like to see it released under the GPL"
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ ./configure --kernel-path="${KV_DIR}" \
+ || die "could not configure"
+
+ make
+}
+
+src_install() {
+ linux-mod_src_install
+
+ # udev rule
+ dodir /etc/udev/rules.d/
+ echo 'KERNEL="kqemu*", NAME="%k", GROUP="qemu", MODE="0660"' > ${D}/etc/udev/rules.d/48-qemu.rules
+ enewgroup qemu
+
+ # Module doc
+ dodoc ${S}/README
+ dohtml ${S}/kqemu-doc.html
+
+ # module params
+ dodir /etc/modules.d
+ echo "options kqemu major=0" > ${D}/etc/modules.d/kqemu
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo "Make sure you have the kernel module loaded before running qemu"
+ einfo "and your user is in the qemu group"
+}