summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-08 15:58:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-08 15:58:05 +0000
commitc0802c8857c11a63e0098e73a9aeeb081f56552f (patch)
tree7c035c4183b02f86d0fe12045f482aafeace0d4e /app-emulation
parentNon-Maintainer Commit: Applying patch for CVE-2008-5371, bug 250476. (diff)
downloadgentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.tar.gz
gentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.tar.bz2
gentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.zip
Initial commit. Fixes bug 184112
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qtemu/ChangeLog13
-rw-r--r--app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch63
-rw-r--r--app-emulation/qtemu/metadata.xml9
-rw-r--r--app-emulation/qtemu/qtemu-1.0.5.ebuild31
4 files changed, 116 insertions, 0 deletions
diff --git a/app-emulation/qtemu/ChangeLog b/app-emulation/qtemu/ChangeLog
new file mode 100644
index 000000000000..93a1e0586d56
--- /dev/null
+++ b/app-emulation/qtemu/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/qtemu
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qtemu/ChangeLog,v 1.1 2009/06/08 15:58:04 hwoarang Exp $
+
+*qtemu-1.0.5 (08 Jun 2009)
+
+ 08 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/1.0.5-help_and_translation_paths.patch, +qtemu-1.0.5.ebuild,
+ +metadata.xml:
+ Initial commit of qtemu application. Thanks to Tiziano Müller for the
+ ebuild.
+ Fixes bug 184112
+
diff --git a/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
new file mode 100644
index 000000000000..8fc1680aacb0
--- /dev/null
+++ b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
@@ -0,0 +1,63 @@
+diff -Naur qtemu-1.0.5.orig/CMakeLists.txt qtemu-1.0.5/CMakeLists.txt
+--- qtemu-1.0.5.orig/CMakeLists.txt 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/CMakeLists.txt 2008-02-22 19:35:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ DEPENDS ${QM_FILES})
+
+ INSTALL (FILES ${QM_FILES}
+- DESTINATION translations)
++ DESTINATION share/qtemu/translations)
+ # translation end
+
+ SET(QT_USE_QTXML)
+@@ -146,13 +146,13 @@
+ )
+
+ FILE(GLOB helpfiles "${CMAKE_CURRENT_SOURCE_DIR}/help/*.png")
+-INSTALL(FILES ${helpfiles} DESTINATION help)
++INSTALL(FILES ${helpfiles} DESTINATION share/qtemu/help)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION help)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION share/qtemu/help)
+
+ FILE(GLOB helpfiles_de "${CMAKE_CURRENT_SOURCE_DIR}/help/de/*.png")
+-INSTALL(FILES ${helpfiles_de} DESTINATION help/de)
++INSTALL(FILES ${helpfiles_de} DESTINATION share/qtemu/help/de)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION help/de)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION share/qtemu/help/de)
+
+ INSTALL(TARGETS qtemu DESTINATION bin)
+diff -Naur qtemu-1.0.5.orig/helpwindow.cpp qtemu-1.0.5/helpwindow.cpp
+--- qtemu-1.0.5.orig/helpwindow.cpp 2008-02-22 19:32:44.000000000 +0100
++++ qtemu-1.0.5/helpwindow.cpp 2008-02-22 19:33:26.000000000 +0100
+@@ -80,7 +80,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/" + locale + "/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/" + locale + "/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+ }
+@@ -96,7 +96,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+
+diff -Naur qtemu-1.0.5.orig/main.cpp qtemu-1.0.5/main.cpp
+--- qtemu-1.0.5.orig/main.cpp 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/main.cpp 2008-02-22 19:36:32.000000000 +0100
+@@ -45,7 +45,7 @@
+ translator.load(path);
+ else
+ {
+- path = QCoreApplication::applicationDirPath()+"/../translations/qtemu_" + locale + ".qm";
++ path = QCoreApplication::applicationDirPath()+"/../share/qtemu/translations/qtemu_" + locale + ".qm";
+ if (QFile::exists(path))
+ translator.load(path);
+ }
diff --git a/app-emulation/qtemu/metadata.xml b/app-emulation/qtemu/metadata.xml
new file mode 100644
index 000000000000..eabd7789e502
--- /dev/null
+++ b/app-emulation/qtemu/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emulation/qtemu/qtemu-1.0.5.ebuild b/app-emulation/qtemu/qtemu-1.0.5.ebuild
new file mode 100644
index 000000000000..38ff3c3c40d2
--- /dev/null
+++ b/app-emulation/qtemu/qtemu-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qtemu/qtemu-1.0.5.ebuild,v 1.1 2009/06/08 15:58:04 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4 cmake-utils
+
+DESCRIPTION="A graphical user interface for QEMU written in Qt4."
+HOMEPAGE="http://qtemu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CCPL-Attribution-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ app-emulation/qemu"
+
+DOCS="ChangeLog README"
+PATCHES=(
+ "${FILESDIR}/${PV}-help_and_translation_paths.patch"
+)
+
+src_install() {
+ cmake-utils_src_install
+ doicon "${S}/images/${PN}.ico"
+ make_desktop_entry "qtemu" "QtEmu" "${PN}.ico" "Qt;Utility;Emulator"
+}