summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-02-02 21:58:31 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-02-02 21:58:31 +0000
commitcc9c8bbbae119adbd7683d824faa7bf467d6f9d8 (patch)
treeed3ec77815216d3b495de5e31891210ef3cac8c0 /app-emulation
parentfixed svrpport used up from vdr-1.7.15 (diff)
downloadgentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.tar.gz
gentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.tar.bz2
gentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.zip
Version bump to support CPU model/features, support graphics (vnc, sdl, spice) configs, and support skipping the install and just dumping the XML. Additionally added a missing depend on libxml2.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtinst/ChangeLog10
-rw-r--r--app-emulation/virtinst/virtinst-0.500.4.ebuild7
-rw-r--r--app-emulation/virtinst/virtinst-0.500.5.ebuild47
-rw-r--r--app-emulation/virtinst/virtinst-9999.ebuild7
4 files changed, 64 insertions, 7 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index ea3130232433..842e1e3631ac 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.21 2011/01/13 22:31:58 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.22 2011/02/02 21:58:31 cardoe Exp $
+
+*virtinst-0.500.5 (02 Feb 2011)
+
+ 02 Feb 2011; Doug Goldstein <cardoe@gentoo.org> virtinst-0.500.4.ebuild,
+ +virtinst-0.500.5.ebuild, virtinst-9999.ebuild:
+ Version bump to support CPU model/features, support graphics (vnc, sdl,
+ spice) configs, and support skipping the install and just dumping the XML.
+ Additionally added a missing depend on libxml2.
13 Jan 2011; Doug Goldstein <cardoe@gentoo.org> virtinst-9999.ebuild:
Accidently left keywords in globally when they're defined for each version
diff --git a/app-emulation/virtinst/virtinst-0.500.4.ebuild b/app-emulation/virtinst/virtinst-0.500.4.ebuild
index 8a4ceda6d513..cec79846c3e7 100644
--- a/app-emulation/virtinst/virtinst-0.500.4.ebuild
+++ b/app-emulation/virtinst/virtinst-0.500.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.4.ebuild,v 1.2 2010/09/02 19:51:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.4.ebuild,v 1.3 2011/02/02 21:58:31 cardoe Exp $
BACKPORTS=1
@@ -21,7 +21,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=app-emulation/libvirt-0.7.0[python]
- dev-python/urlgrabber"
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
DEPEND="${RDEPEND}"
PYTHON_MODNAME="virtconv virtinst"
diff --git a/app-emulation/virtinst/virtinst-0.500.5.ebuild b/app-emulation/virtinst/virtinst-0.500.5.ebuild
new file mode 100644
index 000000000000..8f0a70d3abc8
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.500.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.5.ebuild,v 1.1 2011/02/02 21:58:31 cardoe Exp $
+
+#BACKPORTS=1
+
+EAPI=3
+
+if [[ ${PV} = *9999* ]]; then
+ EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
+ HG_ECLASS="mercurial autotools"
+fi
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${HG_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}
diff --git a/app-emulation/virtinst/virtinst-9999.ebuild b/app-emulation/virtinst/virtinst-9999.ebuild
index 9dee8fd047ea..88acfd3b906b 100644
--- a/app-emulation/virtinst/virtinst-9999.ebuild
+++ b/app-emulation/virtinst/virtinst-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-9999.ebuild,v 1.3 2011/01/13 22:31:58 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-9999.ebuild,v 1.4 2011/02/02 21:58:31 cardoe Exp $
#BACKPORTS=1
-EAPI=2
+EAPI=3
if [[ ${PV} = *9999* ]]; then
EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
@@ -32,7 +32,8 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
RDEPEND=">=app-emulation/libvirt-0.7.0[python]
- dev-python/urlgrabber"
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
DEPEND="${RDEPEND}"
PYTHON_MODNAME="virtconv virtinst"