summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-28 07:57:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-28 07:57:22 +0000
commitd8e2e1e6fc557b24c56cf781a187fd47481ace4d (patch)
treeb5c6e6bf5bcefa0d82c808f264aca0d593dfd5fa /app-emulation
parentAdd live ebuild and drop oldest (diff)
downloadgentoo-2-d8e2e1e6fc557b24c56cf781a187fd47481ace4d.tar.gz
gentoo-2-d8e2e1e6fc557b24c56cf781a187fd47481ace4d.tar.bz2
gentoo-2-d8e2e1e6fc557b24c56cf781a187fd47481ace4d.zip
Small sandbox fix, closes 253134. Patch originally from RB.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog6
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.1-sandbox-fix.patch21
-rw-r--r--app-emulation/xen-tools/xen-tools-3.3.1.ebuild4
3 files changed, 29 insertions, 2 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index a30e279ec66f..065521f773a6 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.45 2009/04/27 15:44:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.46 2009/04/28 07:57:21 patrick Exp $
+
+ 28 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/xen-tools-3.3.1-sandbox-fix.patch, xen-tools-3.3.1:
+ Small sandbox fix, closes 253134. Patch originally from RB.
27 Apr 2009; Patrick Lauer <patrick@gentoo.org> xen-tools-3.3.1:
Bump to eapi2 for usedeps, fixing depends for use=doc, closes #199764
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.1-sandbox-fix.patch b/app-emulation/xen-tools/files/xen-tools-3.3.1-sandbox-fix.patch
new file mode 100644
index 000000000000..be0527a7c8f8
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.1-sandbox-fix.patch
@@ -0,0 +1,21 @@
+diff -urN xen-3.3.1/tools/ioemu-qemu-xen/xen-setup xen-3.3.1-fix/tools/ioemu-qemu-xen/xen-setup
+--- xen-3.3.1/tools/ioemu-qemu-xen/xen-setup 2009-01-05 04:36:22.000000000 -0700
++++ xen-3.3.1-fix/tools/ioemu-qemu-xen/xen-setup 2009-04-25 17:55:03.000000000 -0600
+@@ -3,6 +3,8 @@
+
+ # git-clean -x -d && ./xen-setup && make prefix=/usr CMDLINE_CFLAGS='-O0 -g' -j4 && make install DESTDIR=`pwd`/dist/ prefix=/usr && rsync -a --stats --delete . thule:shadow/qemu-iwj.git/ && rsync -a --stats dist/. root@thule:/
+
++target=i386-dm
++
+ rm -f $target/Makefile
+ rm -f $target/config.mak
+ rm -f config-host.mak
+@@ -11,8 +13,6 @@
+
+ ./configure --disable-gfx-check --disable-gcc-check --disable-curses --disable-slirp "$@" --prefix=/usr
+
+-target=i386-dm
+-
+ if [ "x$XEN_ROOT" != x ]; then
+ echo "XEN_ROOT=$XEN_ROOT" >>config-host.mak
+ fi
diff --git a/app-emulation/xen-tools/xen-tools-3.3.1.ebuild b/app-emulation/xen-tools/xen-tools-3.3.1.ebuild
index afd53547b22a..159c2e5b3276 100644
--- a/app-emulation/xen-tools/xen-tools-3.3.1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.3.1.ebuild,v 1.2 2009/04/27 15:44:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.3.1.ebuild,v 1.3 2009/04/28 07:57:21 patrick Exp $
EAPI="2"
@@ -127,6 +127,8 @@ src_unpack() {
# Do not strip binaries
epatch "${FILESDIR}/${PN}-3.3.0-nostrip.patch"
+ # fix variable declaration to avoid sandbox issue, #253134
+ epatch "${FILESDIR}/${PN}-3.3.1-sandbox-fix.patch"
}
src_compile() {