summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-10-24 13:26:25 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-10-24 13:26:25 +0000
commitde0fe493f695ec0346672787ff4169ff148b51f6 (patch)
treed5cc6f425d90a70c7a48f9ed0ab54ba29b4397ef /app-emulation
parentbochs debugger (diff)
downloadgentoo-2-de0fe493f695ec0346672787ff4169ff148b51f6.tar.gz
gentoo-2-de0fe493f695ec0346672787ff4169ff148b51f6.tar.bz2
gentoo-2-de0fe493f695ec0346672787ff4169ff148b51f6.zip
debugger use flag
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 0a5e4f3d3087..b474a2f65fba 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.28 2004/09/23 22:43:09 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.29 2004/10/24 13:26:25 lu_zero Exp $
+
+ 24 Oct 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.1.ebuild:
+ Added debugger useflag, should address the bug #25227
24 Sep 2004; Luca Barbato <lu_zero@gentoo.org> :
Start using wxwidgets eclass
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index 7c7711811689..7eb218efa94c 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.9 2004/09/23 22:43:09 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.10 2004/10/24 13:26:25 lu_zero Exp $
inherit eutils wxwidgets
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
-IUSE="sdl wxwindows readline gtk2"
+IUSE="sdl wxwindows readline gtk2 debugger"
DEPEND="virtual/libc
virtual/x11
@@ -43,9 +43,14 @@ src_compile() {
[ "$ARCH" == "x86" ] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
- use wxwindows && myconf="${myconf} --with-gtk --with-wx"
- use wxwindows || myconf="${myconf} --without-gtk --without-wx"
myconf="${myconf} `use_enable readline`"
+ use wxwindows && \
+ myconf="${myconf} --with-gtk --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-gtk --without-wx"
+ use bochs-debugger && \
+ myconf="$myconf --enable-debugger --enable-disasm
+ --enable-x86-debugger"
./configure \
--enable-fpu --enable-cdrom --enable-control-panel \