summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-04-24 18:03:00 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-04-24 18:03:00 +0000
commite49bf91f6249276a9db04a15285419fdb8266856 (patch)
tree1bbda6c21ed56f8a2d08e601deb4ebcbf402e1f9 /app-emulation
parentVersion bump, supports new formats. Clean post install message (diff)
downloadgentoo-2-e49bf91f6249276a9db04a15285419fdb8266856.tar.gz
gentoo-2-e49bf91f6249276a9db04a15285419fdb8266856.tar.bz2
gentoo-2-e49bf91f6249276a9db04a15285419fdb8266856.zip
Bump to 1.20.6, add lua support. Thanks to slepnoga.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libguestfs/ChangeLog7
-rw-r--r--app-emulation/libguestfs/libguestfs-1.20.6.ebuild153
2 files changed, 159 insertions, 1 deletions
diff --git a/app-emulation/libguestfs/ChangeLog b/app-emulation/libguestfs/ChangeLog
index 79d70250ec4a..15dd83de2028 100644
--- a/app-emulation/libguestfs/ChangeLog
+++ b/app-emulation/libguestfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libguestfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.27 2013/03/25 12:59:11 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.28 2013/04/24 18:03:00 maksbotan Exp $
+
+*libguestfs-1.20.6 (24 Apr 2013)
+
+ 24 Apr 2013; Maxim Koltsov <maksbotan@gentoo.org> +libguestfs-1.20.6.ebuild:
+ Bump to 1.20.6, add lua support. Thanks to slepnoga.
25 Mar 2013; Maxim Koltsov <maksbotan@gentoo.org>
+files/1.20/0001_add_gentoo_names_to_configure.patch,
diff --git a/app-emulation/libguestfs/libguestfs-1.20.6.ebuild b/app-emulation/libguestfs/libguestfs-1.20.6.ebuild
new file mode 100644
index 000000000000..26e908228e6c
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.20.6.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/libguestfs-1.20.6.ebuild,v 1.1 2013/04/24 18:03:00 maksbotan Exp $
+
+EAPI="5"
+
+WANT_LIBTOOL=latest
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit bash-completion-r1 autotools-utils versionator eutils \
+multilib linux-info perl-module
+
+MY_PV_1="$(get_version_component_range 1-2)"
+MY_PV_2="$(get_version_component_range 2)"
+
+[[ $(( $(get_version_component_range 2) % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspect and modifying virtual machine (VM) disk images"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+
+KEYWORDS="~amd64"
+IUSE="erlang +fuse debug ocaml doc +perl ruby static-libs
+selinux systemtap introspection inspect-icons test lua"
+
+# Failires - doc
+
+COMMON_DEPEND="
+ sys-libs/ncurses
+ sys-devel/gettext
+ >=app-misc/hivex-1.3.1
+ dev-libs/libpcre
+ app-arch/cpio
+ dev-lang/perl
+ app-cdr/cdrkit
+ >=app-emulation/qemu-1.2.2[qemu_user_targets_x86_64,qemu_softmmu_targets_x86_64,tci,systemtap?,selinux?,filecaps]
+ sys-apps/fakeroot
+ sys-apps/file
+ app-emulation/libvirt
+ dev-libs/libxml2:2
+ >=sys-apps/fakechroot-2.8
+ >=app-admin/augeas-0.7.1
+ sys-fs/squashfs-tools
+ dev-libs/libconfig
+ dev-libs/libpcre
+ sys-libs/readline
+ >=sys-libs/db-4.6
+ perl? ( virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ virtual/perl-Getopt-Long
+ virtual/perl-Data-Dumper
+ dev-perl/libintl-perl
+ >=app-misc/hivex-1.3.1[perl?]
+ dev-perl/String-ShellQuote
+ )
+ fuse? ( sys-fs/fuse )
+ introspection? (
+ >=dev-libs/gobject-introspection-1.30.0
+ dev-libs/gjs
+ )
+ selinux? ( sys-libs/libselinux sys-libs/libsemanage )
+ systemtap? ( dev-util/systemtap )
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ dev-ml/ocaml-gettext
+ )
+ erlang? ( dev-lang/erlang )
+ inspect-icons? ( media-libs/netpbm
+ media-gfx/icoutils
+ )
+ virtual/acl
+ sys-libs/libcap
+ lua? ( dev-lang/lua )
+ "
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gperf
+ doc? ( app-text/po4a )
+ ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
+ "
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+ "
+
+PATCHES=("${FILESDIR}"/1.20/0*.patch )
+
+DOCS=(AUTHORS BUGS ChangeLog HACKING README ROADMAP TODO)
+
+pkg_setup () {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [ -n "${CONFIG_CHECK}" ] && check_extra_config;
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ local myeconfargs=(
+ $(use_enable test gcc-warnings)
+ --disable-appliance
+ --disable-daemon
+ --with-extra="-gentoo"
+ --with-readline
+ --disable-php
+ --disable-python
+ --without-java
+ $(use_enable perl)
+ $(use_enable fuse)
+ $(use_enable ocaml)
+ $(use_enable ruby)
+ --disable-haskell
+ $(use_enable doc)
+ $(use_enable introspection gobject)
+ $(use_enable erlang)
+ $(use_enable systemtap probes)
+ $(use_enable lua)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+}
+
+src_test() {
+ autotools-utils_src_test
+}
+
+src_install() {
+ strip-linguas -i po
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ dobashcomp "${D}/etc"/bash_completion.d/guestfish-bash-completion.sh
+
+ rm -fr "${D}/etc"/bash* || die
+
+ use perl && fixlocalpod
+}