summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-25 04:27:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-25 04:27:35 +0000
commitee61155dc70e8eeb90ba1defbf4328b9c7a5707e (patch)
tree670570dd78051dc97ab98afb5c337665c9c1a0d5 /app-emulation
parentlicense for vm-arm #93488 (diff)
downloadgentoo-2-ee61155dc70e8eeb90ba1defbf4328b9c7a5707e.tar.gz
gentoo-2-ee61155dc70e8eeb90ba1defbf4328b9c7a5707e.tar.bz2
gentoo-2-ee61155dc70e8eeb90ba1defbf4328b9c7a5707e.zip
initial import #93488
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vm-arm/ChangeLog8
-rw-r--r--app-emulation/vm-arm/Manifest2
-rw-r--r--app-emulation/vm-arm/files/digest-vm-arm-1.0.11
-rw-r--r--app-emulation/vm-arm/metadata.xml5
-rw-r--r--app-emulation/vm-arm/vm-arm-1.0.1.ebuild53
5 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/vm-arm/ChangeLog b/app-emulation/vm-arm/ChangeLog
new file mode 100644
index 000000000000..651777fb59ea
--- /dev/null
+++ b/app-emulation/vm-arm/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/vm-arm
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/ChangeLog,v 1.1 2005/05/25 04:27:35 vapier Exp $
+
+*vm-arm-1.0.1 (25 May 2005)
+
+ 25 May 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Yuri Vasilevski #93488.
diff --git a/app-emulation/vm-arm/Manifest b/app-emulation/vm-arm/Manifest
new file mode 100644
index 000000000000..4aecc53fbfd6
--- /dev/null
+++ b/app-emulation/vm-arm/Manifest
@@ -0,0 +1,2 @@
+MD5 9b96c897b991bf0eabaae96ca7e4cfb2 vm-arm-1.0.1.ebuild 1453
+MD5 37ea286f6d3fc98b3eae3bfd80d2f092 files/digest-vm-arm-1.0.1 80
diff --git a/app-emulation/vm-arm/files/digest-vm-arm-1.0.1 b/app-emulation/vm-arm/files/digest-vm-arm-1.0.1
new file mode 100644
index 000000000000..7e0b67d23f02
--- /dev/null
+++ b/app-emulation/vm-arm/files/digest-vm-arm-1.0.1
@@ -0,0 +1 @@
+MD5 5cf4b706883ff35e47032e042e585397 vm-arm-se-1.0.1-9.suse9_2.i686.rpm 2024620
diff --git a/app-emulation/vm-arm/metadata.xml b/app-emulation/vm-arm/metadata.xml
new file mode 100644
index 000000000000..5454528f2093
--- /dev/null
+++ b/app-emulation/vm-arm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>arm</herd>
+</pkgmetadata>
diff --git a/app-emulation/vm-arm/vm-arm-1.0.1.ebuild b/app-emulation/vm-arm/vm-arm-1.0.1.ebuild
new file mode 100644
index 000000000000..fb451ec58505
--- /dev/null
+++ b/app-emulation/vm-arm/vm-arm-1.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/vm-arm-1.0.1.ebuild,v 1.1 2005/05/25 04:27:35 vapier Exp $
+
+inherit eutils rpm
+
+# - Debian version is very old
+# - Redhat/Fedora ones link against funky ssl
+# - SuSe or MDK rpm's are the only ones that will really work
+RPM_VER="9.suse9_2"
+DESCRIPTION="highly optimized and accurate simulation of the ARM architecture"
+HOMEPAGE="http://www.virtera.com/"
+SRC_URI="vm-arm-se-${PV}-${RPM_VER}.i686.rpm"
+
+LICENSE="VIRTERA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+DEPEND="=dev-libs/openssl-0.9.7*
+ =x11-libs/wxGTK-2.4*"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if ! built_with_use x11-libs/wxGTK wxgtk1 ; then
+ eerror "Please emerge x11-libs/wxGTK-2.4 with wxgtk1 in USE flags."
+ die "GTK1 support in 11-libs/wxGTK-2.4 needed to run ${P}."
+ fi
+}
+
+pkg_nofetch() {
+ einfo "You need to perform the following steps to install this package:"
+ einfo " - Sign up at ${HOMEPAGE}"
+ einfo " - Check your email and visit the download location"
+ einfo " - Download ${A} and place it in ${DISTDIR}"
+ einfo " - emerge this package"
+ einfo " - Put your license in ~/.virtera/"
+}
+
+src_install() {
+ mv opt "${D}"/ || die
+ dodir /opt/bin
+ cd "${D}"
+ for x in opt/virtera/vm-arm-se-${PV}/bin/* ; do
+ dosym /${x} /opt/bin/${x##*/}
+ done
+}
+
+pkg_postinst() {
+ einfo "Please remember to put your license in ~/.virtera/"
+}