summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-05-06 22:08:57 +0000
committerMichael Januszewski <spock@gentoo.org>2005-05-06 22:08:57 +0000
commitfe145bca379f1bdbac560490504cab2437a96d45 (patch)
tree901bf5099a950f9784586d45df1b728860691201 /app-emulation
parentxcruise was renamed by upstream to xcruiser (diff)
downloadgentoo-2-fe145bca379f1bdbac560490504cab2437a96d45.tar.gz
gentoo-2-fe145bca379f1bdbac560490504cab2437a96d45.tar.bz2
gentoo-2-fe145bca379f1bdbac560490504cab2437a96d45.zip
Version bump.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uade/ChangeLog8
-rw-r--r--app-emulation/uade/files/digest-uade-1.021
-rw-r--r--app-emulation/uade/uade-1.01.ebuild4
-rw-r--r--app-emulation/uade/uade-1.02.ebuild57
4 files changed, 67 insertions, 3 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 443d50c31284..1cb0b9e37049 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.23 2005/04/21 18:57:57 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.24 2005/05/06 22:08:57 spock Exp $
+
+*uade-1.02 (06 May 2005)
+
+ 06 May 2005; Michał Januszewski <spock@gentoo.org> uade-1.01.ebuild,
+ +uade-1.02.ebuild:
+ Version bump (bug #91608). Marked 1.01 stable on x86.
21 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org> uade-1.00.ebuild,
uade-1.01.ebuild:
diff --git a/app-emulation/uade/files/digest-uade-1.02 b/app-emulation/uade/files/digest-uade-1.02
new file mode 100644
index 000000000000..d7841358ce96
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-1.02
@@ -0,0 +1 @@
+MD5 8cfb4eb55dbe762f0af84fb7560b75ac uade-1.02.tar.bz2 2363942
diff --git a/app-emulation/uade/uade-1.01.ebuild b/app-emulation/uade/uade-1.01.ebuild
index 92cb14d79348..09025394d4b9 100644
--- a/app-emulation/uade/uade-1.01.ebuild
+++ b/app-emulation/uade/uade-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.01.ebuild,v 1.2 2005/04/21 18:57:57 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.01.ebuild,v 1.3 2005/05/06 22:08:57 spock Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE="xmms sdl alsa oss perl bmp"
RDEPEND="virtual/libc
diff --git a/app-emulation/uade/uade-1.02.ebuild b/app-emulation/uade/uade-1.02.ebuild
new file mode 100644
index 000000000000..68000a034fa1
--- /dev/null
+++ b/app-emulation/uade/uade-1.02.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.02.ebuild,v 1.1 2005/05/06 22:08:57 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://uade.ton.tut.fi/"
+SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="xmms sdl alsa oss perl bmp"
+
+RDEPEND="virtual/libc
+ xmms? ( >=media-sound/xmms-1.2.2
+ x11-libs/gtk+ )
+ sdl? ( media-libs/libsdl )
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ bmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+
+DEPEND="${RDEPEND}
+ xmms? ( sys-devel/libtool )"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_with oss) \
+ $(use_with sdl) \
+ $(use_with alsa) \
+ $(use_with xmms) \
+ $(use_with bmp) \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc BUGS ChangeLog.txt FIXED ANTIPLANS README PLANS TESTING docs/CREDITS
+
+ find "${D}/usr/share/doc/${PF}/" \
+ \( -name '*.readme' -o \
+ -name '*.txt' -o \
+ -name 'INSTALL*' -o \
+ -name 'README*' -o \
+ -name 'Change*' \) -exec gzip -9 \{\} \;
+ dohtml -r "${D}/usr/share/doc/${PF}/"
+ rm -f "${D}/usr/share/doc/${PF}/"{COPYING,INSTALL.*.gz}
+ rm -f "${D}/usr/share/doc/${PF}/uade-docs/"{*.html,*.png,*.1}
+
+ if ! use perl; then
+ rm -f "${D}/usr/bin/pwrap.pl"
+ fi
+}