summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-04-02 13:16:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-04-02 13:16:37 +0000
commit98f28d0e0335b1e45d2b9c71572235a077f92be9 (patch)
tree29d5c0a0ffff54bd638886918126206f07c10a4c /app-forensics/afflib
parentRemove virtual/libpcap wrt #358835. (diff)
downloadgentoo-2-98f28d0e0335b1e45d2b9c71572235a077f92be9.tar.gz
gentoo-2-98f28d0e0335b1e45d2b9c71572235a077f92be9.tar.bz2
gentoo-2-98f28d0e0335b1e45d2b9c71572235a077f92be9.zip
Bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog9
-rw-r--r--app-forensics/afflib/afflib-3.6.8.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index e58b5327799e..121a678ec48c 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.8 2010/02/26 20:25:22 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.9 2011/04/02 13:16:37 patrick Exp $
+
+*afflib-3.6.8 (02 Apr 2011)
+
+ 02 Apr 2011; Patrick Lauer <patrick@gentoo.org> +afflib-3.6.8.ebuild:
+ Bump
*afflib-3.5.8 (26 Feb 2010)
diff --git a/app-forensics/afflib/afflib-3.6.8.ebuild b/app-forensics/afflib/afflib-3.6.8.ebuild
new file mode 100644
index 000000000000..abd1cbe10105
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.6.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.8.ebuild,v 1.1 2011/04/02 13:16:37 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}