summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-07 04:42:32 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-07 04:42:32 +0000
commit53a107f571aaf780743ac194a35873921a82cac7 (patch)
tree72bcd236153ed6dd5ab2b89799b17e74204067b8 /app-forensics/libewf
parentVersion bump. (diff)
downloadgentoo-2-53a107f571aaf780743ac194a35873921a82cac7.tar.gz
gentoo-2-53a107f571aaf780743ac194a35873921a82cac7.tar.bz2
gentoo-2-53a107f571aaf780743ac194a35873921a82cac7.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-forensics/libewf')
-rw-r--r--app-forensics/libewf/ChangeLog7
-rw-r--r--app-forensics/libewf/libewf-20130331.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 9bab72c1606f..19a2ce2f376b 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.43 2013/04/02 23:08:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.44 2013/04/07 04:42:32 radhermit Exp $
+
+*libewf-20130331 (07 Apr 2013)
+
+ 07 Apr 2013; Tim Harder <radhermit@gentoo.org> +libewf-20130331.ebuild:
+ Version bump.
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> libewf-20130128.ebuild:
Stable for hppa, wrt bug #463020
diff --git a/app-forensics/libewf/libewf-20130331.ebuild b/app-forensics/libewf/libewf-20130331.ebuild
new file mode 100644
index 000000000000..3fa23054244f
--- /dev/null
+++ b/app-forensics/libewf/libewf-20130331.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20130331.ebuild,v 1.1 2013/04/07 04:42:32 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://code.google.com/p/libewf/"
+SRC_URI="http://libewf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug ewf +fuse rawio +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable rawio low-level-functions)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}