summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-02-18 11:25:18 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-02-18 11:25:18 +0000
commit19b0f1e9a532c6c09667386699140ba9b72de664 (patch)
treefe0b736b6a3d32fa7e31fe2f228e9d8871fe024d /app-forensics/rkhunter/rkhunter-1.2.9.ebuild
parentStable on ppc wrt bug 167391 (diff)
downloadgentoo-2-19b0f1e9a532c6c09667386699140ba9b72de664.tar.gz
gentoo-2-19b0f1e9a532c6c09667386699140ba9b72de664.tar.bz2
gentoo-2-19b0f1e9a532c6c09667386699140ba9b72de664.zip
version bump as per bug #149951
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-forensics/rkhunter/rkhunter-1.2.9.ebuild')
-rw-r--r--app-forensics/rkhunter/rkhunter-1.2.9.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-forensics/rkhunter/rkhunter-1.2.9.ebuild b/app-forensics/rkhunter/rkhunter-1.2.9.ebuild
new file mode 100644
index 000000000000..53a5cf44adae
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.2.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.2.9.ebuild,v 1.1 2007/02/18 11:25:18 dragonheart Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/rkhunter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/mta
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof"
+
+S="${WORKDIR}/${P}/files"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.1-create-tmpdir.diff
+ epatch "${FILESDIR}"/${PN}-1.2.9-ppc64.patch
+}
+
+src_install() {
+ insinto /usr/lib/rkhunter/db
+ doins *.dat || die "failed to install dat files"
+
+ exeinto /usr/lib/rkhunter/scripts
+ doexe *.pl check_update.sh || die "failed to install scripts"
+
+ dobin rkhunter || die "failed to install rkhunter script"
+
+ insinto /etc
+ doins rkhunter.conf || die "failed to install rkhunter.conf"
+ dosed 's:^#\(DBDIR=.*\)local\(.*\)$:\1lib\2\nINSTALLDIR=/usr:' \
+ /etc/rkhunter.conf || die "sed rkhunter.conf failed"
+
+ doman development/rkhunter.8 || die "doman failed"
+ dodoc CHANGELOG LICENSE README WISHLIST || die "dodoc failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/rkhunter.cron rkhunter || \
+ die "failed to install cron script"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+}
+
+pkg_postinst() {
+ echo
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ echo
+ bash-completion_pkg_postinst
+}
+
+pkg_prerm() {
+ rm -rf /usr/lib/rkhunter/tmp
+}