summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-27 08:52:16 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-27 08:52:16 +0000
commit8a116080ebeea8cbc39aee59305a2f36413d3489 (patch)
tree3672dad1849d285b036a6f8aff82838b08cdb283 /app-forensics
parentFixes psipred detection, python file patches (diff)
downloadgentoo-2-8a116080ebeea8cbc39aee59305a2f36413d3489.tar.gz
gentoo-2-8a116080ebeea8cbc39aee59305a2f36413d3489.tar.bz2
gentoo-2-8a116080ebeea8cbc39aee59305a2f36413d3489.zip
Use upstream versioning and fix build with Linux 3.x (bug #383803 by Diego Elio Pettenò).
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/memdump/ChangeLog9
-rw-r--r--app-forensics/memdump/files/memdump-1.01-linux3.patch24
-rw-r--r--app-forensics/memdump/memdump-1.01.ebuild (renamed from app-forensics/memdump/memdump-1.0.1.ebuild)12
3 files changed, 37 insertions, 8 deletions
diff --git a/app-forensics/memdump/ChangeLog b/app-forensics/memdump/ChangeLog
index be059a6ce4ba..736d033b2e21 100644
--- a/app-forensics/memdump/ChangeLog
+++ b/app-forensics/memdump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/memdump
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/memdump/ChangeLog,v 1.9 2011/06/26 07:17:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/memdump/ChangeLog,v 1.10 2011/09/27 08:52:16 radhermit Exp $
+
+*memdump-1.01 (27 Sep 2011)
+
+ 27 Sep 2011; Tim Harder <radhermit@gentoo.org> -memdump-1.0.1.ebuild,
+ +memdump-1.01.ebuild, +files/memdump-1.01-linux3.patch:
+ Use upstream versioning and fix build with Linux 3.x (bug #383803 by Diego
+ Elio Pettenò).
26 Jun 2011; Tim Harder <radhermit@gentoo.org> memdump-1.0.1.ebuild:
Respect LDFLAGS (bug #337739), respect CC (bug #243594), don't test FEATURES
diff --git a/app-forensics/memdump/files/memdump-1.01-linux3.patch b/app-forensics/memdump/files/memdump-1.01-linux3.patch
new file mode 100644
index 000000000000..55563c4e077a
--- /dev/null
+++ b/app-forensics/memdump/files/memdump-1.01-linux3.patch
@@ -0,0 +1,24 @@
+--- memdump-1.01.orig/makedefs
++++ memdump-1.01/makedefs
+@@ -30,9 +30,7 @@
+ SunOS.5*) DEFS="-DSUNOS5 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ RANLIB=":"
+ ;;
+- Linux.2.4*) DEFS="-DLINUX2 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+- ;;
+- Linux.2*) DEFS="-DLINUX2"
++ Linux.*) DEFS="-DLINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ ;;
+ *) echo unsupported system: $SYSTEM.$RELEASE 1>&2; exit 1
+ ;;
+--- memdump-1.01.orig/memdump.c
++++ memdump-1.01/memdump.c
+@@ -118,7 +118,7 @@
+ #define SUPPORTED
+ #endif
+
+-#ifdef LINUX2
++#ifdef LINUX
+ #include <paths.h>
+ #define GETPAGESIZE getpagesize
+ #define SUPPORTED
diff --git a/app-forensics/memdump/memdump-1.0.1.ebuild b/app-forensics/memdump/memdump-1.01.ebuild
index 4e61e4d207c6..c94c34fe3ab9 100644
--- a/app-forensics/memdump/memdump-1.0.1.ebuild
+++ b/app-forensics/memdump/memdump-1.01.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/memdump/memdump-1.0.1.ebuild,v 1.4 2011/06/26 07:17:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/memdump/memdump-1.01.ebuild,v 1.1 2011/09/27 08:52:16 radhermit Exp $
EAPI=4
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Simple memory dumper for UNIX-Like systems"
HOMEPAGE="http://www.porcupine.org/forensics"
-SRC_URI="http://www.porcupine.org/forensics/${PN}-1.01.tar.gz"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
LICENSE="IBM"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND=""
-RDEPEND=""
IUSE=""
-S=${WORKDIR}/${PN}-1.01
-
src_prepare() {
sed -i -e 's:$(CFLAGS):\0 $(LDFLAGS):' Makefile || die
+ epatch "${FILESDIR}"/${P}-linux3.patch
}
src_compile() {