summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-11-16 20:31:51 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-11-16 20:31:51 +0000
commit701222ae509352fe72bc5d4d1d5f60af237bb460 (patch)
tree829b3146ede3c5b32f191afa7997f02b96144626 /app-i18n/enca/enca-1.9-r1.ebuild
parentFixed wrong installation path for man pages (bug #246661) and not respecting ... (diff)
downloadgentoo-2-701222ae509352fe72bc5d4d1d5f60af237bb460.tar.gz
gentoo-2-701222ae509352fe72bc5d4d1d5f60af237bb460.tar.bz2
gentoo-2-701222ae509352fe72bc5d4d1d5f60af237bb460.zip
Bump to fix compilation with gcc-4.3 and glibc-2.8. Since we changed how its built slightly, a bump seemed necessary, thanks to Thomas 'gimpel' Kuther for the new ebuild; bug #226083
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.1 x86_64)
Diffstat (limited to 'app-i18n/enca/enca-1.9-r1.ebuild')
-rw-r--r--app-i18n/enca/enca-1.9-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-i18n/enca/enca-1.9-r1.ebuild b/app-i18n/enca/enca-1.9-r1.ebuild
new file mode 100644
index 000000000000..16b2f9577de2
--- /dev/null
+++ b/app-i18n/enca/enca-1.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.9-r1.ebuild,v 1.1 2008/11/16 20:31:51 halcy0n Exp $
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://trific.ath.cx/software/enca/"
+SRC_URI="http://trific.ath.cx/Ftp/enca/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="app-text/recode"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ --with-librecode=/usr \
+ --enable-external \
+ $(use_enable doc gtk-doc) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}