summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2012-05-15 01:57:23 +0000
committerMu Qiao <qiaomuf@gentoo.org>2012-05-15 01:57:23 +0000
commit78ad361f27bebca771e5007199bceec6b08031c0 (patch)
tree756a01b88c9e81f14785745529187565e22dfd90 /app-i18n/fcitx
parentInitial version. (diff)
downloadgentoo-2-78ad361f27bebca771e5007199bceec6b08031c0.tar.gz
gentoo-2-78ad361f27bebca771e5007199bceec6b08031c0.tar.bz2
gentoo-2-78ad361f27bebca771e5007199bceec6b08031c0.zip
Version bump for fcitx-4.2.3
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/ChangeLog7
-rw-r--r--app-i18n/fcitx/fcitx-4.2.3.ebuild119
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.3-fix-lua.patch64
3 files changed, 189 insertions, 1 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 28aaed6b30fd..91aae4500017 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/fcitx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.46 2012/05/03 19:24:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.47 2012/05/15 01:57:23 qiaomuf Exp $
+
+*fcitx-4.2.3 (15 May 2012)
+
+ 15 May 2012; Mu Qiao <qiaomuf@gentoo.org> +fcitx-4.2.3.ebuild:
+ Version bump for fcitx-4.2.3
03 May 2012; Jeff Horelick <jdhore@gentoo.org> fcitx-3.6.3.ebuild,
fcitx-3.6.4.ebuild, fcitx-4.0.0.ebuild, fcitx-4.0.1.ebuild,
diff --git a/app-i18n/fcitx/fcitx-4.2.3.ebuild b/app-i18n/fcitx/fcitx-4.2.3.ebuild
new file mode 100644
index 000000000000..19a1d2b7bd59
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-4.2.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.2.3.ebuild,v 1.1 2012/05/15 01:57:23 qiaomuf Exp $
+
+EAPI="3"
+
+inherit multilib cmake-utils eutils
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz
+ http://fcitx.googlecode.com/files/pinyin.tar.gz
+ table? ( http://fcitx.googlecode.com/files/table.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cairo debug gtk gtk3 lua opencc +pango qt static-libs +table test"
+
+RDEPEND="
+ cairo? (
+ x11-libs/cairo[X]
+ pango? ( x11-libs/pango[X] )
+ !pango? ( media-libs/fontconfig )
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ )
+ gtk3? (
+ x11-libs/gtk+:3
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ )
+ lua? ( dev-lang/lua )
+ opencc? ( app-i18n/opencc )
+ qt? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-dbus:4
+ )
+ sys-apps/dbus
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/intltool
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+update_gtk_immodules() {
+ local GTK2_CONFDIR="/etc/gtk-2.0"
+ # bug #366889
+ if has_version '>=x11-libs/gtk+-2.22.1-r1:2' || has_multilib_profile ; then
+ GTK2_CONFDIR="${GTK2_CONFDIR}/$(get_abi_CHOST)"
+ fi
+ mkdir -p "${EPREFIX}${GTK2_CONFDIR}"
+
+ if [ -x "${EPREFIX}/usr/bin/gtk-query-immodules-2.0" ] ; then
+ "${EPREFIX}/usr/bin/gtk-query-immodules-2.0" > "${EPREFIX}${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+update_gtk3_immodules() {
+ if [ -x "${EPREFIX}/usr/bin/gtk-query-immodules-3.0" ] ; then
+ "${EPREFIX}/usr/bin/gtk-query-immodules-3.0" --update-cache
+ fi
+}
+
+src_prepare() {
+ cp "${DISTDIR}/pinyin.tar.gz" "${S}/data" || die "pinyin.tar.gz is not found"
+ if use table ; then
+ cp "${DISTDIR}/table.tar.gz" "${S}/data/table" || die "table.tar.gz is not found"
+ fi
+
+ epatch "${FILESDIR}"/${P}-fix-lua.patch
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DLIB_INSTALL_DIR=/usr/$(get_libdir)
+ $(cmake-utils_use_enable cairo CARIO)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable gtk GTK2_IM_MODULE)
+ $(cmake-utils_use_enable gtk3 GTK3_IM_MODULE)
+ $(cmake-utils_use_enable lua LUA)
+ $(cmake-utils_use_enable opencc OPENCC)
+ $(cmake-utils_use_enable pango PANGO)
+ $(cmake-utils_use_enable qt QT_IM_MODULE)
+ $(cmake-utils_use_enable static-libs STATIC)
+ $(cmake-utils_use_enable table TABLE)
+ $(cmake-utils_use_enable test TEST)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS ChangeLog README THANKS TODO || die
+
+ rm -rf "${ED}"/usr/share/fcitx/doc/ || die
+ dodoc doc/pinyin.txt doc/cjkvinput.txt || die
+ dohtml doc/wb_fh.htm || die
+}
+
+pkg_postinst() {
+ use gtk && update_gtk_immodules
+ use gtk3 && update_gtk3_immodules
+ elog
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=fcitx"
+ elog " export XIM_PROGRAM=fcitx"
+ elog
+}
+
+pkg_postrm() {
+ use gtk && update_gtk_immodules
+ use gtk3 && update_gtk3_immodules
+}
diff --git a/app-i18n/fcitx/files/fcitx-4.2.3-fix-lua.patch b/app-i18n/fcitx/files/fcitx-4.2.3-fix-lua.patch
new file mode 100644
index 000000000000..d08b636c639b
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.2.3-fix-lua.patch
@@ -0,0 +1,64 @@
+commit e8e378f7e12f1a755a0912dff15e9f84ad8dbd7f
+Author: Weng Xuetian <wengxt@gmail.com>
+Date: Mon May 7 14:06:25 2012 +0800
+
+ fix compile
+
+diff --git a/src/module/lua/luawrap.c b/src/module/lua/luawrap.c
+index 67883a7..417a1c9 100644
+--- a/src/module/lua/luawrap.c
++++ b/src/module/lua/luawrap.c
+@@ -58,13 +58,13 @@ typedef struct _ConverterItem {
+ UT_hash_handle hh;
+ } ConverterItem;
+
+-typedef struct _LuaExtension {
++struct _LuaExtension {
+ char *name;
+ lua_State *lua;
+ UT_hash_handle hh;
+-} LuaExtension;
++};
+
+-typedef struct _LuaModule {
++struct _LuaModule {
+ FcitxInstance *fcitx;
+ LuaExtension *extensions;
+ CommandItem *commands;
+@@ -73,7 +73,7 @@ typedef struct _LuaModule {
+ ConverterItem *converters;
+ ConverterItem *current_converter;
+ size_t shortest_input_trigger_key_length;
+-} LuaModule;
++};
+
+ typedef void (*LuaResultFn)(LuaModule *luamodule, const char *in, const char *out);
+
+diff --git a/src/module/lua/luawrap.h b/src/module/lua/luawrap.h
+index 152d835..592b275 100644
+--- a/src/module/lua/luawrap.h
++++ b/src/module/lua/luawrap.h
+@@ -21,18 +21,18 @@
+ #ifndef _LUA_WRAP_H_
+ #define _LUA_WRAP_H_
+
+-typedef struct lua_State lua_State;
+-typedef struct _LuaModule LuaModule;
+-typedef struct _LuaExtension LuaExtension;
+-typedef struct _FcitxInstance FcitxInstance;
++#include <lua.h>
+
+ typedef struct _LuaResultItem {
+ char *result;
+ char *help;
+ } LuaResultItem;
+
++typedef struct _LuaModule LuaModule;
++typedef struct _LuaExtension LuaExtension;
++
+ // alloc/free luamodule
+-LuaModule * LuaModuleAlloc(FcitxInstance *fcitx);
++LuaModule * LuaModuleAlloc(struct _FcitxInstance *fcitx);
+ void LuaModuleFree(LuaModule *luamodule);
+ FcitxInstance *GetFcitx(LuaModule *luamodule);
+