summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-05 11:33:29 +0000
committerBen de Groot <yngwin@gentoo.org>2013-02-05 11:33:29 +0000
commitf2631ac3a6e84cf425e324a75d4e2dce3cb68ee6 (patch)
treefc309671417002d571b3bdee009e88e1e78ca801 /app-i18n/ibus-anthy
parentversion bump, remove old (diff)
downloadgentoo-2-f2631ac3a6e84cf425e324a75d4e2dce3cb68ee6.tar.gz
gentoo-2-f2631ac3a6e84cf425e324a75d4e2dce3cb68ee6.tar.bz2
gentoo-2-f2631ac3a6e84cf425e324a75d4e2dce3cb68ee6.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog7
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 87d1755e11ad..d827efa70152 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.40 2013/01/09 13:05:12 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.41 2013/02/05 11:33:29 yngwin Exp $
+
+*ibus-anthy-1.5.0 (05 Feb 2013)
+
+ 05 Feb 2013; Ben de Groot <yngwin@gentoo.org> +ibus-anthy-1.5.0.ebuild:
+ version bump
09 Jan 2013; <naota@gentoo.org> ibus-anthy-1.2.6.ebuild,
ibus-anthy-1.2.7-r1.ebuild, ibus-anthy-1.2.7.ebuild:
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.0.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.0.ebuild
new file mode 100644
index 000000000000..3ae656663b10
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.5.0.ebuild,v 1.1 2013/02/05 11:33:29 yngwin Exp $
+
+EAPI=5
+PYTHON_DEPEND="2:2.5"
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20100111
+ app-i18n/anthy
+ >=dev-python/pygtk-2.15.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile #397497
+ sed -i -e "s/python/python2/" \
+ engine/ibus-engine-anthy.in setup/ibus-setup-anthy.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}