summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-02 16:26:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-02 16:26:28 +0000
commit429993296192059432b41060b5b26402aec78469 (patch)
tree40b6892de2c5888d301edcaead14171253ec7109 /app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild
parentInitial import. (diff)
downloadgentoo-2-429993296192059432b41060b5b26402aec78469.tar.gz
gentoo-2-429993296192059432b41060b5b26402aec78469.tar.bz2
gentoo-2-429993296192059432b41060b5b26402aec78469.zip
Initial import.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild')
-rw-r--r--app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild b/app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild
new file mode 100644
index 000000000000..fcc3c86f5b6a
--- /dev/null
+++ b/app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-erbi/ibus-table-erbi-0.1.2.20090101.ebuild,v 1.1 2009/01/02 16:26:28 matsuu Exp $
+
+DESCRIPTION="The ErBi for IBus Tables"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-phrases minimal"
+
+RDEPEND=">=app-i18n/ibus-table-0.1.2
+ extra-phrases? ( >=app-i18n/ibus-table-extraphrase-0.1.2 )
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable !minimal erbi-qs) \
+ $(use_enable extra-phrases) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}