summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 11:31:15 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 11:31:15 +0000
commit2e45bca1320cbe8e4f92af13e44dff95e6365c6d (patch)
tree1f5a3dfa4964a0f74d3a3ee41fcade38510889cc /app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild
parentConvert to python-single-r1. (diff)
downloadgentoo-2-2e45bca1320cbe8e4f92af13e44dff95e6365c6d.tar.gz
gentoo-2-2e45bca1320cbe8e4f92af13e44dff95e6365c6d.tar.bz2
gentoo-2-2e45bca1320cbe8e4f92af13e44dff95e6365c6d.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild')
-rw-r--r--app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild b/app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..3881324e396b
--- /dev/null
+++ b/app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-tutcode/ibus-tutcode-1.0.2-r1.ebuild,v 1.1 2014/12/27 11:31:15 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="a Japanese TUT-Code input engine for IBus"
+HOMEPAGE="https://github.com/deton/ibus-tutcode/"
+SRC_URI="mirror://github/deton/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+CDEPEND="${PYTHON_DEPS}
+ >=sys-devel/gettext-0.16.1"
+DEPEND="${CDEPEND}
+ test? ( app-i18n/ibus )"
+RDEPEND="${CDEPEND}
+ app-i18n/ibus"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ sed -i -e "s/python/${EPYTHON}/" engine/ibus-engine-tutcode.in || die
+}
+
+src_install() {
+ default
+ dodoc ${PN}.json.example
+}