summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-05-04 00:17:24 +0000
committerNaohiro Aota <naota@gentoo.org>2013-05-04 00:17:24 +0000
commit297750160da5375c4c6cbfa872cc74c1d756549c (patch)
treedb517039358fab5ffb2428295def3bd2245c5c35 /app-i18n/imsettings
parentMigrate to vala.eclass #467382 (diff)
downloadgentoo-2-297750160da5375c4c6cbfa872cc74c1d756549c.tar.gz
gentoo-2-297750160da5375c4c6cbfa872cc74c1d756549c.tar.bz2
gentoo-2-297750160da5375c4c6cbfa872cc74c1d756549c.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/imsettings')
-rw-r--r--app-i18n/imsettings/ChangeLog8
-rw-r--r--app-i18n/imsettings/imsettings-1.5.0.ebuild76
-rw-r--r--app-i18n/imsettings/metadata.xml2
3 files changed, 85 insertions, 1 deletions
diff --git a/app-i18n/imsettings/ChangeLog b/app-i18n/imsettings/ChangeLog
index 6975b64df6ea..11e01dd8828c 100644
--- a/app-i18n/imsettings/ChangeLog
+++ b/app-i18n/imsettings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/imsettings
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.14 2013/03/02 19:27:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.15 2013/05/04 00:17:24 naota Exp $
+
+*imsettings-1.5.0 (04 May 2013)
+
+ 04 May 2013; Naohiro Aota <naota@gentoo.org> +imsettings-1.5.0.ebuild,
+ metadata.xml:
+ Version bump.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> imsettings-1.2.4.ebuild,
imsettings-1.2.5.ebuild, imsettings-1.2.6.ebuild, imsettings-1.2.8.1.ebuild:
diff --git a/app-i18n/imsettings/imsettings-1.5.0.ebuild b/app-i18n/imsettings/imsettings-1.5.0.ebuild
new file mode 100644
index 000000000000..6768716a2bd9
--- /dev/null
+++ b/app-i18n/imsettings/imsettings-1.5.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/imsettings-1.5.0.ebuild,v 1.1 2013/05/04 00:17:24 naota Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Delivery framework for general Input Method configuration"
+HOMEPAGE="http://tagoh.github.com/imsettings/"
+SRC_URI="http://imsettings.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gconf gtk3 qt4 static-libs xfconf"
+
+# X11 connections are required for test.
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/check-0.9.4
+ >=dev-libs/glib-2.26
+ sys-apps/dbus
+ >=x11-libs/gtk+-2.12:2
+ >=x11-libs/libgxim-0.3.1
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ gconf? ( gnome-base/gconf )
+ gtk3? ( x11-libs/gtk+:3 )
+ qt4? ( dev-qt/qtcore:4 )
+ xfconf? ( xfce-base/xfconf )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+MY_XINPUTSH="90-xinput"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # Prevent automagic linking to libxfconf-0.
+ if ! use gconf; then
+ sed -i -e 's:gconf-2.0:dIsAbLe&:' configure || die
+ fi
+ if ! use gtk3; then
+ sed -i -e 's:gtk+-3.0:dIsAbLe&:' configure || die
+ fi
+ if ! use qt4; then
+ sed -i -e 's:QtCore:dIsAbLe&:' configure || die
+ fi
+ if ! use xfconf; then
+ sed -i -e 's:libxfconf-0:dIsAbLe&:' configure || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-xinputsh="${MY_XINPUTSH}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+
+ fperms 0755 /usr/libexec/xinputinfo.sh
+ fperms 0755 "/etc/X11/xinit/xinitrc.d/${MY_XINPUTSH}"
+}
+
+pkg_postinst() {
+ if [ ! -e "${EPREFIX}/etc/X11/xinit/xinputrc" ] ; then
+ ln -sf xinput.d/xcompose.conf "${EPREFIX}/etc/X11/xinit/xinputrc"
+ fi
+}
diff --git a/app-i18n/imsettings/metadata.xml b/app-i18n/imsettings/metadata.xml
index ab4f7701afa5..6a110ec0e896 100644
--- a/app-i18n/imsettings/metadata.xml
+++ b/app-i18n/imsettings/metadata.xml
@@ -4,5 +4,7 @@
<herd>cjk</herd>
<use>
<flag name='xfconf'>Enable integration in the Xfce desktop environment with <pkg>xfce-base/xfconf</pkg></flag>
+ <flag name='gconf'>Enable GConf support</flag>
+ <flag name='gtk3'>Enable support for <pkg>x11-libs/gtk+</pkg>:3</flag>
</use>
</pkgmetadata>