summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2014-01-10 10:13:52 +0000
committerNaohiro Aota <naota@gentoo.org>2014-01-10 10:13:52 +0000
commit889819c8f067f662d34ed8cbbb624dab26f12a44 (patch)
tree78d4ae2a24bffa837b35ca1cee4721e3f695ef97 /app-i18n/imsettings
parentAdd ~ia64 keyword wrt bug #497394 (diff)
downloadgentoo-2-889819c8f067f662d34ed8cbbb624dab26f12a44.tar.gz
gentoo-2-889819c8f067f662d34ed8cbbb624dab26f12a44.tar.bz2
gentoo-2-889819c8f067f662d34ed8cbbb624dab26f12a44.zip
Add a patch to deal with latest gir-scanner. #485800
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/imsettings')
-rw-r--r--app-i18n/imsettings/ChangeLog8
-rw-r--r--app-i18n/imsettings/files/imsettings-1.5.0-gir-scanner.patch29
-rw-r--r--app-i18n/imsettings/imsettings-1.5.0.ebuild8
3 files changed, 40 insertions, 5 deletions
diff --git a/app-i18n/imsettings/ChangeLog b/app-i18n/imsettings/ChangeLog
index 11e01dd8828c..ad4f28154e00 100644
--- a/app-i18n/imsettings/ChangeLog
+++ b/app-i18n/imsettings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/imsettings
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.15 2013/05/04 00:17:24 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/ChangeLog,v 1.16 2014/01/10 10:13:52 naota Exp $
+
+ 10 Jan 2014; Naohiro Aota <naota@gentoo.org>
+ +files/imsettings-1.5.0-gir-scanner.patch, imsettings-1.5.0.ebuild:
+ Add a patch to deal with latest gir-scanner. #485800
*imsettings-1.5.0 (04 May 2013)
diff --git a/app-i18n/imsettings/files/imsettings-1.5.0-gir-scanner.patch b/app-i18n/imsettings/files/imsettings-1.5.0-gir-scanner.patch
new file mode 100644
index 000000000000..be7350f9401f
--- /dev/null
+++ b/app-i18n/imsettings/files/imsettings-1.5.0-gir-scanner.patch
@@ -0,0 +1,29 @@
+From 75e1ec9cea4bb9f108c0637a4b62cabfa500ed61 Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Wed, 3 Apr 2013 19:37:15 +0900
+Subject: [PATCH] Fix a build issue with the latest gobject-introspection
+
+---
+ imsettings/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/imsettings/Makefile.am b/imsettings/Makefile.am
+index 574480a..8e5999a 100644
+--- a/imsettings/Makefile.am
++++ b/imsettings/Makefile.am
+@@ -117,9 +117,11 @@ IMSettings_1_3_gir_INCLUDES = \
+ GObject-2.0 \
+ Gio-2.0 \
+ $(NULL)
++IMSettings_1_3_gir_SCANNERFLAGS = \
++ --symbol-prefix=imsettings \
++ $(NULL)
+ IMSettings_1_3_gir_CFLAGS = \
+ $(INCLUDES) \
+- --symbol-prefix=imsettings \
+ $(NULL)
+ IMSettings_1_3_gir_LIBS = libimsettings.la
+ IMSettings_1_3_gir_FILES = $(introspection_sources)
+--
+1.8.5.2
+
diff --git a/app-i18n/imsettings/imsettings-1.5.0.ebuild b/app-i18n/imsettings/imsettings-1.5.0.ebuild
index 6768716a2bd9..5ee07aa2a455 100644
--- a/app-i18n/imsettings/imsettings-1.5.0.ebuild
+++ b/app-i18n/imsettings/imsettings-1.5.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/imsettings-1.5.0.ebuild,v 1.1 2013/05/04 00:17:24 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imsettings/imsettings-1.5.0.ebuild,v 1.2 2014/01/10 10:13:52 naota Exp $
EAPI=5
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Delivery framework for general Input Method configuration"
HOMEPAGE="http://tagoh.github.com/imsettings/"
@@ -52,6 +52,8 @@ src_prepare() {
if ! use xfconf; then
sed -i -e 's:libxfconf-0:dIsAbLe&:' configure || die
fi
+ epatch "${FILESDIR}"/${P}-gir-scanner.patch
+ eautoreconf
}
src_configure() {