summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-10-28 13:27:58 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-10-28 13:27:58 +0000
commit7f483710b6369cf90c8d9234ee1d2703e90bf6ba (patch)
tree2d7fe9943072da675f2fe1954000e361975e8726 /app-i18n/kcc/kcc-1.0.ebuild
parentNew version (diff)
downloadgentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.tar.gz
gentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.tar.bz2
gentoo-2-7f483710b6369cf90c8d9234ee1d2703e90bf6ba.zip
intial ebuild submission
Diffstat (limited to 'app-i18n/kcc/kcc-1.0.ebuild')
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
new file mode 100644
index 000000000000..14806663851d
--- /dev/null
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#
+
+KEYWORDS="~x86"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A Kanji code converter"
+SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+HOMEPAGE="" #There doesn't seem to be a home page for this package!
+LICENSE="GPL2"
+
+DEPEND="virtual/glibc"
+
+SLOT=0
+
+src_unpack() {
+
+ # unpack the archive
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}/gentoo.diff || die
+}
+
+src_compile() {
+ make
+}
+
+src_install () {
+
+ # install libs, executables, dictionaries
+ make DESTDIR=${D} install || die "installation failed"
+
+ # install docs
+ dodoc README
+}