summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-10-29 06:32:47 +0000
committerMamoru Komachi <usata@gentoo.org>2005-10-29 06:32:47 +0000
commit4e585e231c9362adaa7b92d32b7494a8d5fd0dd4 (patch)
treebe8efac2b7a3a4dbb9d723ef67e168fd3c567bb4 /app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild
parentStable on x86 (diff)
downloadgentoo-2-4e585e231c9362adaa7b92d32b7494a8d5fd0dd4.tar.gz
gentoo-2-4e585e231c9362adaa7b92d32b7494a8d5fd0dd4.tar.bz2
gentoo-2-4e585e231c9362adaa7b92d32b7494a8d5fd0dd4.zip
Version bumped.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild b/app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild
new file mode 100644
index 000000000000..f7aa07a22b71
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-0.7.1.ebuild,v 1.1 2005/10/29 06:32:47 usata Exp $
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/16945/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )"
+RDEPEND="${DEPEND}
+ app-dicts/kasumi"
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM, you should use the following in your user startup scripts"
+ einfo "such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=scim"
+ einfo "export QT_IM_MODULE=scim"
+ einfo
+}