summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 12:24:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 12:24:14 +0000
commit11adf1fee899096a0eaff09ac83663245d744411 (patch)
tree8f9037d2d35234214fe01edcd3999ded86704320 /app-i18n/scim-hangul
parentAdd patch to build with GCC 4.3. Thanks to Marek Miller in bug #223161. (diff)
downloadgentoo-2-11adf1fee899096a0eaff09ac83663245d744411.tar.gz
gentoo-2-11adf1fee899096a0eaff09ac83663245d744411.tar.bz2
gentoo-2-11adf1fee899096a0eaff09ac83663245d744411.zip
Add patch to build with GCC 4.3. Thanks to Steve Warren in bug #222557.
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-i18n/scim-hangul')
-rw-r--r--app-i18n/scim-hangul/ChangeLog8
-rw-r--r--app-i18n/scim-hangul/files/scim-hangul-0.3.2+gcc-4.3.patch23
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild10
3 files changed, 37 insertions, 4 deletions
diff --git a/app-i18n/scim-hangul/ChangeLog b/app-i18n/scim-hangul/ChangeLog
index a403d9bc3fb9..abdb2f4ebb9f 100644
--- a/app-i18n/scim-hangul/ChangeLog
+++ b/app-i18n/scim-hangul/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/scim-hangul
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.23 2007/12/31 14:37:39 matsuu Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.24 2008/06/09 12:24:14 flameeyes Exp $
+
+ 09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/scim-hangul-0.3.2+gcc-4.3.patch, scim-hangul-0.3.2.ebuild:
+ Add patch to build with GCC 4.3. Thanks to Steve Warren in bug #222557.
*scim-hangul-0.3.2 (31 Dec 2007)
diff --git a/app-i18n/scim-hangul/files/scim-hangul-0.3.2+gcc-4.3.patch b/app-i18n/scim-hangul/files/scim-hangul-0.3.2+gcc-4.3.patch
new file mode 100644
index 000000000000..b7698793ac8e
--- /dev/null
+++ b/app-i18n/scim-hangul/files/scim-hangul-0.3.2+gcc-4.3.patch
@@ -0,0 +1,23 @@
+diff -up scim-hangul-0.3.2/src/scim_hangul_imengine.cpp.gcc43~ scim-hangul-0.3.2/src/scim_hangul_imengine.cpp
+--- scim-hangul-0.3.2/src/scim_hangul_imengine.cpp.gcc43~ 2008-01-13 08:01:34.000000000 +0000
++++ scim-hangul-0.3.2/src/scim_hangul_imengine.cpp 2008-01-13 08:01:34.000000000 +0000
+@@ -29,6 +29,7 @@
+ #define Uses_SCIM_LOOKUP_TABLE
+ #define Uses_SCIM_CONFIG_BASE
+
++#include <cstring>
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+diff -up scim-hangul-0.3.2/src/scim_hangul_imengine_setup.cpp.gcc43~ scim-hangul-0.3.2/src/scim_hangul_imengine_setup.cpp
+--- scim-hangul-0.3.2/src/scim_hangul_imengine_setup.cpp.gcc43~ 2008-01-13 08:01:37.000000000 +0000
++++ scim-hangul-0.3.2/src/scim_hangul_imengine_setup.cpp 2008-01-13 08:01:37.000000000 +0000
+@@ -28,7 +28,8 @@
+
+ #define Uses_SCIM_CONFIG_BASE
+
++#include <cstring>
+ #include <gtk/gtk.h>
+
+ #ifdef HAVE_CONFIG_H
+
diff --git a/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild b/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild
index 26fbb366163e..499c9085e774 100644
--- a/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild
+++ b/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild,v 1.1 2007/12/31 14:37:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.3.2.ebuild,v 1.2 2008/06/09 12:24:14 flameeyes Exp $
+
+inherit base
DESCRIPTION="Hangul IMEngine for SCIM ported from imhangul"
HOMEPAGE="http://www.scim-im.org/"
@@ -19,6 +21,10 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${P}+gcc-4.3.patch
+)
+
src_compile() {
econf \
$(use_enable kde skim-support) \