summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-24 14:49:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-24 14:49:28 +0000
commit974f5252b23398c232c390093f1c94d55aff1583 (patch)
tree49ff8a830ae318dfa32764d2292357024cb175ac /app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild
parentSparc stable --- Bug #260088 which see for brief comments. (diff)
downloadgentoo-2-974f5252b23398c232c390093f1c94d55aff1583.tar.gz
gentoo-2-974f5252b23398c232c390093f1c94d55aff1583.tar.bz2
gentoo-2-974f5252b23398c232c390093f1c94d55aff1583.zip
-m
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild')
-rw-r--r--app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild b/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild
new file mode 100644
index 000000000000..880655a29318
--- /dev/null
+++ b/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild,v 1.1 2009/02/24 14:49:28 matsuu Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit kde-functions eutils autotools
+
+DESCRIPTION="Smart Common Input Method (SCIM) Smart Pinyin Input Method"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+IUSE="kde nls"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libXt
+ || ( >=app-i18n/scim-1.1 >=app-i18n/scim-cvs-1.1 )
+ kde? ( >=app-i18n/skim-1.2 )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fixconfigure.patch"
+ epatch "${FILESDIR}/${PN}-qt335.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-gbk.patch"
+
+ AT_M4DIR=m4 AT_NO_RECURSIVE=yes eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable kde skim-support) \
+ --without-arts \
+ --disable-static \
+ --disable-depedency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README ChangeLog
+}