summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-01 02:46:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-01 02:46:54 +0000
commit259e68c793b880bc89e032d17f7e24a8e549c6e9 (patch)
tree93b6aed5227bf9082aea480d96770a1da53d2407 /app-i18n/skkfep
parentamd64 stable, bug #244915 (diff)
downloadgentoo-2-259e68c793b880bc89e032d17f7e24a8e549c6e9.tar.gz
gentoo-2-259e68c793b880bc89e032d17f7e24a8e549c6e9.tar.bz2
gentoo-2-259e68c793b880bc89e032d17f7e24a8e549c6e9.zip
CFLAGS and CC support, bug #240050 and #243598. Fixed QA issue and dependency. Added ~amd64.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-i18n/skkfep')
-rw-r--r--app-i18n/skkfep/ChangeLog11
-rw-r--r--app-i18n/skkfep/files/skkfep-0.87-gentoo.patch131
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild38
3 files changed, 178 insertions, 2 deletions
diff --git a/app-i18n/skkfep/ChangeLog b/app-i18n/skkfep/ChangeLog
index 75d58cf32287..d6bd85c0cc12 100644
--- a/app-i18n/skkfep/ChangeLog
+++ b/app-i18n/skkfep/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/skkfep
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkfep/ChangeLog,v 1.8 2007/02/21 22:13:31 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkfep/ChangeLog,v 1.9 2008/11/01 02:46:54 matsuu Exp $
+
+*skkfep-0.87-r1 (01 Nov 2008)
+
+ 01 Nov 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/skkfep-0.87-gentoo.patch, +skkfep-0.87-r1.ebuild:
+ CFLAGS and CC support, bug #240050 and #243598. Fixed QA issue and
+ dependency. Added ~amd64.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-i18n/skkfep/files/skkfep-0.87-gentoo.patch b/app-i18n/skkfep/files/skkfep-0.87-gentoo.patch
new file mode 100644
index 000000000000..bd1b507580bc
--- /dev/null
+++ b/app-i18n/skkfep/files/skkfep-0.87-gentoo.patch
@@ -0,0 +1,131 @@
+diff -Naur skkfep-0.87.orig/config.h skkfep-0.87/config.h
+--- skkfep-0.87.orig/config.h 2003-09-03 08:50:18.000000000 +0900
++++ skkfep-0.87/config.h 2008-11-01 09:53:22.000000000 +0900
+@@ -24,8 +24,8 @@
+ /* SKK server */
+
+ #define USER_DIC_NAME ".skk-jisyo"
+-/* #define SYSTEM_DIC_NAME "/usr/local/emacs/etc/SKK-JISYO.L" */
++#define SYSTEM_DIC_NAME "/usr/share/skk/SKK-JISYO.L"
+
+ #define NATIVECODE euc /* EUC Kanji code */
+
+-#define SKK_SERVER_HOST "ei5nazha" /* SKK server host */
++#define SKK_SERVER_HOST "localhost" /* SKK server host */
+diff -Naur skkfep-0.87.orig/connserv.c skkfep-0.87/connserv.c
+--- skkfep-0.87.orig/connserv.c 2003-09-03 08:49:30.000000000 +0900
++++ skkfep-0.87/connserv.c 2008-11-01 09:59:19.000000000 +0900
+@@ -5,6 +5,7 @@
+ */
+ #include "config.h"
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include "skklib.h"
+
+diff -Naur skkfep-0.87.orig/connsh.c skkfep-0.87/connsh.c
+--- skkfep-0.87.orig/connsh.c 2003-09-03 08:49:30.000000000 +0900
++++ skkfep-0.87/connsh.c 2008-11-01 10:03:01.000000000 +0900
+@@ -1,5 +1,8 @@
+ #include "config.h"
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/file.h>
+ #include <fcntl.h>
+diff -Naur skkfep-0.87.orig/fep.c skkfep-0.87/fep.c
+--- skkfep-0.87.orig/fep.c 2003-09-03 08:49:31.000000000 +0900
++++ skkfep-0.87/fep.c 2008-11-01 09:55:15.000000000 +0900
+@@ -1,6 +1,7 @@
+ #include "config.h"
+ #include "fep.h"
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include "kanjicode.h"
+diff -Naur skkfep-0.87.orig/jc.c skkfep-0.87/jc.c
+--- skkfep-0.87.orig/jc.c 2003-09-03 08:49:31.000000000 +0900
++++ skkfep-0.87/jc.c 2008-11-01 09:54:57.000000000 +0900
+@@ -33,6 +33,8 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <ctype.h>
+
+ #include "config.h"
+diff -Naur skkfep-0.87.orig/kkconv.c skkfep-0.87/kkconv.c
+--- skkfep-0.87.orig/kkconv.c 2003-09-03 08:49:31.000000000 +0900
++++ skkfep-0.87/kkconv.c 2008-11-01 09:58:26.000000000 +0900
+@@ -1,6 +1,7 @@
+ #include "config.h"
+ #include "fep.h"
+ #include "functions.h"
++#include <string.h>
+ #include <ctype.h>
+
+ #ifdef USE_SERVER
+diff -Naur skkfep-0.87.orig/protoMakefile skkfep-0.87/protoMakefile
+--- skkfep-0.87.orig/protoMakefile 2003-09-03 08:49:31.000000000 +0900
++++ skkfep-0.87/protoMakefile 2008-11-01 09:51:59.000000000 +0900
+@@ -1,5 +1,5 @@
+ CFLAGS=$(SYSINCLUDE) $(SYSDEFINE) $(DEFINE) $(OPTIMIZE)
+-LIBS =$(SYSLIBS) $(EXTRALIBS) -ltermcap
++LIBS =$(SYSLIBS) $(EXTRALIBS) -lncurses
+
+ OBJS=fep.o connsh.o readwrite.o terms.o stty.o keybind.o romkan.o etc.o\
+ kkconv.o keymap.o version.o
+diff -Naur skkfep-0.87.orig/readwrite.c skkfep-0.87/readwrite.c
+--- skkfep-0.87.orig/readwrite.c 2003-09-03 08:49:31.000000000 +0900
++++ skkfep-0.87/readwrite.c 2008-11-01 09:56:19.000000000 +0900
+@@ -1,5 +1,6 @@
+ #include "config.h"
+ #include "fep.h"
++#include <string.h>
+ #include <ctype.h>
+ #include "kanjicode.h"
+ #include "ctrlcode.h"
+diff -Naur skkfep-0.87.orig/romkan-org.c skkfep-0.87/romkan-org.c
+--- skkfep-0.87.orig/romkan-org.c 2003-09-03 08:49:32.000000000 +0900
++++ skkfep-0.87/romkan-org.c 2008-11-01 09:58:10.000000000 +0900
+@@ -1,5 +1,6 @@
+ #include "config.h"
+ #include "fep.h"
++#include <string.h>
+ #include <ctype.h>
+ #include "functions.h"
+
+diff -Naur skkfep-0.87.orig/skklib.c skkfep-0.87/skklib.c
+--- skkfep-0.87.orig/skklib.c 2003-09-03 08:49:32.000000000 +0900
++++ skkfep-0.87/skklib.c 2008-11-01 09:58:48.000000000 +0900
+@@ -6,6 +6,7 @@
+
+ #include "config.h"
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include "skklib.h"
+diff -Naur skkfep-0.87.orig/stty.c skkfep-0.87/stty.c
+--- skkfep-0.87.orig/stty.c 2003-09-03 08:49:32.000000000 +0900
++++ skkfep-0.87/stty.c 2008-11-01 09:57:30.000000000 +0900
+@@ -1,5 +1,6 @@
+ #include "config.h"
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <signal.h>
+ #include <fcntl.h>
+ #include "fep.h"
+diff -Naur skkfep-0.87.orig/terms.c skkfep-0.87/terms.c
+--- skkfep-0.87.orig/terms.c 2003-09-03 08:49:32.000000000 +0900
++++ skkfep-0.87/terms.c 2008-11-01 09:56:59.000000000 +0900
+@@ -1,4 +1,5 @@
+ #include "config.h"
++#include <string.h>
+ #include "fep.h"
+
+ /*#define SHOW_ESCSEQ /* show escape sequences for debugging */
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
new file mode 100644
index 000000000000..5814c37a165a
--- /dev/null
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkfep/skkfep-0.87-r1.ebuild,v 1.1 2008/11/01 02:46:54 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A SKK-like Japanese input method for console"
+HOMEPAGE="http://homepage2.nifty.com/aito/soft.html"
+SRC_URI="http://homepage2.nifty.com/aito/skkfep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-apps/gawk"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin skkfep escmode || die
+ doman skkfep.1
+
+ dodoc README HISTORY TODO
+}