summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-09 15:03:45 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-09 15:03:45 +0000
commit7f0c0195d7707cbb55fe37739ccd4784013454c4 (patch)
tree2ca699b1fe9c614f4dc4ff67524f04728e78e680 /app-i18n/xsim
parentMark -sparc, it sigbuses (diff)
downloadgentoo-2-7f0c0195d7707cbb55fe37739ccd4784013454c4.tar.gz
gentoo-2-7f0c0195d7707cbb55fe37739ccd4784013454c4.tar.bz2
gentoo-2-7f0c0195d7707cbb55fe37739ccd4784013454c4.zip
Fixed compile problem on gcc-4.3, bug #227117. Fixed kdelibs dependency, bug #213425.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-i18n/xsim')
-rw-r--r--app-i18n/xsim/ChangeLog10
-rw-r--r--app-i18n/xsim/files/xsim-0.3.9.4-gcc-4.3.patch44
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r2.ebuild5
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r5.ebuild83
4 files changed, 139 insertions, 3 deletions
diff --git a/app-i18n/xsim/ChangeLog b/app-i18n/xsim/ChangeLog
index 70d397afe4ed..bdd7055432a4 100644
--- a/app-i18n/xsim/ChangeLog
+++ b/app-i18n/xsim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/xsim
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.16 2008/05/04 15:06:48 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.17 2008/09/09 15:03:44 matsuu Exp $
+
+*xsim-0.3.9.4-r5 (09 Sep 2008)
+
+ 09 Sep 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/xsim-0.3.9.4-gcc-4.3.patch, xsim-0.3.9.4-r2.ebuild,
+ +xsim-0.3.9.4-r5.ebuild:
+ Fixed compile problem on gcc-4.3, bug #227117. Fixed kdelibs dependency,
+ bug #213425.
04 May 2008; MATSUU Takuto <matsuu@gentoo.org> xsim-0.3.9.4-r2.ebuild,
-xsim-0.3.9.4-r3.ebuild, xsim-0.3.9.4-r4.ebuild:
diff --git a/app-i18n/xsim/files/xsim-0.3.9.4-gcc-4.3.patch b/app-i18n/xsim/files/xsim-0.3.9.4-gcc-4.3.patch
new file mode 100644
index 000000000000..f6df247b03ef
--- /dev/null
+++ b/app-i18n/xsim/files/xsim-0.3.9.4-gcc-4.3.patch
@@ -0,0 +1,44 @@
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/jianpin/dict/char2db.cpp xsim-0.3.9.4/plugins/IMs/jianpin/dict/char2db.cpp
+--- xsim-0.3.9.4.orig/plugins/IMs/jianpin/dict/char2db.cpp 2002-09-23 13:22:39.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/jianpin/dict/char2db.cpp 2008-09-09 18:56:56.000000000 +0900
+@@ -21,6 +21,7 @@
+ #include <clocale>
+ #include <vector>
+ #include <fstream>
++#include <cstdlib>
+
+ #include <db_cxx.h>
+
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/jianpin/dict/word2db.cpp xsim-0.3.9.4/plugins/IMs/jianpin/dict/word2db.cpp
+--- xsim-0.3.9.4.orig/plugins/IMs/jianpin/dict/word2db.cpp 2002-09-23 13:24:17.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/jianpin/dict/word2db.cpp 2008-09-09 18:59:33.000000000 +0900
+@@ -21,6 +21,7 @@
+ #include <string>
+ #include <db_cxx.h>
+ #include <locale.h>
++#include <cstdlib>
+
+ #include "../simpleimc.h"
+
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/table/dict/word2db.cpp xsim-0.3.9.4/plugins/IMs/table/dict/word2db.cpp
+--- xsim-0.3.9.4.orig/plugins/IMs/table/dict/word2db.cpp 2002-09-23 13:34:06.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/table/dict/word2db.cpp 2008-09-09 23:52:31.000000000 +0900
+@@ -21,6 +21,7 @@
+ #include <string>
+ #include <db_cxx.h>
+ #include <clocale>
++#include <cstdlib>
+
+ #include "../tableimc.h"
+
+diff -Naur xsim-0.3.9.4.orig/plugins/IMs/wubi/dict/word2db.cpp xsim-0.3.9.4/plugins/IMs/wubi/dict/word2db.cpp
+--- xsim-0.3.9.4.orig/plugins/IMs/wubi/dict/word2db.cpp 2002-09-23 13:28:45.000000000 +0900
++++ xsim-0.3.9.4/plugins/IMs/wubi/dict/word2db.cpp 2008-09-09 23:19:27.000000000 +0900
+@@ -21,6 +21,7 @@
+ #include <string>
+ #include <db_cxx.h>
+ #include <locale.h>
++#include <cstdlib>
+
+ #include "../wubiimc.h"
+
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
index 05bb1599ed56..d5f4599389e5 100644
--- a/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
+++ b/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild,v 1.11 2008/05/04 15:06:48 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild,v 1.12 2008/09/09 15:03:44 matsuu Exp $
+EAPI="1"
inherit kde-functions eutils
DESCRIPTION="A simple and fast GB and BIG5 Chinese XIM server"
@@ -16,7 +17,7 @@ IUSE="kde"
DEPEND="virtual/libc
>=sys-libs/db-3
>=sys-apps/sed-4
- kde? ( >=kde-base/kdelibs-3 )"
+ kde? ( kde-base/kdelibs:3.5 )"
src_unpack() {
unpack ${A}
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild
new file mode 100644
index 000000000000..715b0cbdc9a9
--- /dev/null
+++ b/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild,v 1.1 2008/09/09 15:03:44 matsuu Exp $
+
+EAPI="1"
+inherit db-use eutils flag-o-matic kde-functions multilib
+
+DESCRIPTION="A simple and fast GB and BIG5 Chinese XIM server"
+HOMEPAGE="http://developer.berlios.de/projects/xsim/"
+SRC_URI="mirror://berlios/xsim/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+DEPEND=">=sys-libs/db-4.1
+ >=sys-apps/sed-4
+ kde? ( kde-base/kdelibs:3.5 )"
+
+src_unpack() {
+ local dbver
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-compile-fix.patch
+ epatch "${FILESDIR}"/${P}-gcc-3.4.patch
+ epatch "${FILESDIR}"/${P}-64bit.patch
+ # bug 227117
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
+ append-flags -DPIC -fPIC -fno-strict-aliasing
+
+ dbver="$(db_findver sys-libs/db)"
+ sed -i -e "s/\(CFLAGS.*\)-O2/\1${CFLAGS}/" \
+ -e "s/libdb_cxx.so/libdb_cxx-${dbver}.so/" \
+ -e "s/bdblib=\"db_cxx\"/bdblib=\"db_cxx-${dbver}\"/" configure* || die
+
+ find . -name '*.in' | xargs sed -i \
+ -e "s#\(@prefix@/\)\(dat\|plugins\)#\1$(get_libdir)/xsim/\2#" \
+ -e "s#@prefix@/etc#/etc#" || die
+}
+
+src_compile() {
+ local myconf
+
+ if use kde; then
+ set-qtdir 3
+ set-kdedir 3
+ myconf="${myconf}
+ --with-kde3=${KDEDIR} \
+ --with-qt3=${QTDIR} \
+ --enable-status-kde3"
+ fi
+
+ myconf="${myconf} --with-bdb-includes=$(db_includedir)"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ xsim_datp="${D}"/usr/$(get_libdir)/xsim/dat \
+ xsim_libp="${D}"usr/$(get_libdir)/xsim/plugins \
+ xsim_binp="${D}"/usr/bin \
+ xsim_etcp="${D}"/etc \
+ install-data install || die "install failed"
+
+ dodoc ChangeLog KNOWNBUG README* TODO
+}
+
+pkg_postinst() {
+ elog "XSIM needs write access to /usr/$(get_libdir)/xsim/dat/chardb, so if you"
+ elog "not running it as root, you need to do the following:"
+ elog
+ elog " cp -r /usr/$(get_libdir)/xsim/dat \${HOME}/.xsim"
+ elog " sed -i \"s#DICT_LOCAL.*#DICT_LOCAL \${HOME}/.xsim#\" > \${HOME}/.xsim/xsimrc"
+ echo
+}