summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-02-28 07:57:50 +0000
committerYixun Lan <dlan@gentoo.org>2015-02-28 07:57:50 +0000
commit36592dc34415c088d14d9c413497c430b3f8a45f (patch)
tree01cee032eaaf403fdd2efdef61d2c0c80b11440e /app-i18n
parentBump (diff)
downloadgentoo-2-36592dc34415c088d14d9c413497c430b3f8a45f.tar.gz
gentoo-2-36592dc34415c088d14d9c413497c430b3f8a45f.tar.bz2
gentoo-2-36592dc34415c088d14d9c413497c430b3f8a45f.zip
version bump, bug 541394, thanks Brendan Horan
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-cangjie/ChangeLog9
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.2.ebuild49
2 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/ibus-cangjie/ChangeLog b/app-i18n/ibus-cangjie/ChangeLog
index f55894ff1986..f0c285dae7b9 100644
--- a/app-i18n/ibus-cangjie/ChangeLog
+++ b/app-i18n/ibus-cangjie/ChangeLog
@@ -1,3 +1,12 @@
+# ChangeLog for app-i18n/ibus-cangjie
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-cangjie/ChangeLog,v 1.4 2015/02/28 07:57:50 dlan Exp $
+
+*ibus-cangjie-2.2 (27 Feb 2015)
+
+ 27 Feb 2015; Yixun Lan <dlan@gentoo.org> +ibus-cangjie-2.2.ebuild:
+ version bump, bug 541394, thanks Brendan Horan
+
*ibus-cangjie-2.1 (24 Apr 2014)
24 Nov 2014; Yixun Lan <dlan@gentoo.org> ibus-cangjie-2.1.ebuild:
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.2.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.2.ebuild
new file mode 100644
index 000000000000..c5f41da0cc9a
--- /dev/null
+++ b/app-i18n/ibus-cangjie/ibus-cangjie-2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-cangjie/ibus-cangjie-2.2.ebuild,v 1.1 2015/02/28 07:57:50 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3,3_4} )
+
+inherit autotools-utils gnome2-utils python-r1 eutils
+
+DESCRIPTION="The IBus engine for users of the Cangjie and Quick input methods"
+HOMEPAGE="http://cangjians.github.io"
+SRC_URI="https://github.com/Cangjians/ibus-cangjie/releases/download/v${PV}/ibus-cangjie-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/ibus-1.4.1
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ dev-util/intltool
+ sys-devel/gettext"
+
+RDEPEND=">=app-i18n/ibus-1.4.1
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ virtual/libintl
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}