summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-25 00:04:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-25 00:04:59 +0000
commit4aee407b4c94ec47b1109357a28288e7ae2c415b (patch)
tree3b9a3d8bce18d59f9cf2ce8c859a205692869b64 /app-i18n
parentFixed live ebuild. Thanks to Dmitry Olyenyov (bug #358459). (diff)
downloadgentoo-2-4aee407b4c94ec47b1109357a28288e7ae2c415b.tar.gz
gentoo-2-4aee407b4c94ec47b1109357a28288e7ae2c415b.tar.bz2
gentoo-2-4aee407b4c94ec47b1109357a28288e7ae2c415b.zip
Fixed to work with >=app-i18n/ibus-1.3.99. Removed old versions.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-hangul/ChangeLog10
-rw-r--r--app-i18n/ibus-hangul/files/ibus-hangul-ibus-1.4.patch155
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild46
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild3
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.3.1-r1.ebuild (renamed from app-i18n/ibus-hangul/ibus-hangul-1.3.0.20100329.ebuild)12
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild3
6 files changed, 175 insertions, 54 deletions
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index fbfeb53d9218..c629cce36a65 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/ibus-hangul
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.13 2011/04/02 02:24:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.14 2011/05/25 00:04:59 matsuu Exp $
+
+*ibus-hangul-1.3.1-r1 (25 May 2011)
+
+ 25 May 2011; MATSUU Takuto <matsuu@gentoo.org>
+ -ibus-hangul-1.1.0.20090328.ebuild, ibus-hangul-1.2.0.20100102.ebuild,
+ -ibus-hangul-1.3.0.20100329.ebuild, ibus-hangul-1.3.1.ebuild,
+ +ibus-hangul-1.3.1-r1.ebuild, +files/ibus-hangul-ibus-1.4.patch:
+ Fixed to work with >=app-i18n/ibus-1.3.99. Removed old versions.
*ibus-hangul-1.3.1 (02 Apr 2011)
diff --git a/app-i18n/ibus-hangul/files/ibus-hangul-ibus-1.4.patch b/app-i18n/ibus-hangul/files/ibus-hangul-ibus-1.4.patch
new file mode 100644
index 000000000000..25a6f1238cac
--- /dev/null
+++ b/app-i18n/ibus-hangul/files/ibus-hangul-ibus-1.4.patch
@@ -0,0 +1,155 @@
+From 6ce58d1d79e5b175865ee26794e9fc7ce576ce56 Mon Sep 17 00:00:00 2001
+From: Daiki Ueno <ueno@unixuser.org>
+Date: Mon, 8 Nov 2010 14:12:35 +0900
+Subject: [PATCH] Fix build with ibus-1.4.
+
+This patch adds compatibility code for the API changes of IBusConfig and
+IBusEngineDesc in ibus-1.3 -> ibus-1.4.
+---
+ src/engine.c | 75 ++++++++++++++++++++++++++++++++++++++++++++++++---------
+ 1 files changed, 63 insertions(+), 12 deletions(-)
+
+diff --git a/src/engine.c b/src/engine.c
+index 79db70f..a297e4d 100644
+--- a/src/engine.c
++++ b/src/engine.c
+@@ -111,7 +111,11 @@ static void ibus_hangul_engine_update_lookup_table
+ static void ibus_config_value_changed (IBusConfig *config,
+ const gchar *section,
+ const gchar *name,
++#if IBUS_CHECK_VERSION(1,3,99)
++ GVariant *value,
++#else
+ GValue *value,
++#endif /* !IBUS_CHECK_VERSION(1,3,99) */
+ gpointer user_data);
+
+ static void lookup_table_set_visible (IBusLookupTable *table,
+@@ -136,6 +140,11 @@ static gboolean hanja_key_list_match (HanjaKeyList *list,
+ static gboolean hanja_key_list_has_modifier (HanjaKeyList *list,
+ guint keyval);
+
++static gboolean config_get_string (IBusConfig *config,
++ const gchar *section,
++ const gchar *name,
++ gchar **result);
++
+ static IBusEngineClass *parent_class = NULL;
+ static HanjaTable *hanja_table = NULL;
+ static HanjaTable *symbol_table = NULL;
+@@ -176,7 +185,7 @@ void
+ ibus_hangul_init (IBusBus *bus)
+ {
+ gboolean res;
+- GValue value = { 0, };
++ gchar *str;
+
+ hanja_table = hanja_table_load (NULL);
+
+@@ -187,22 +196,20 @@ ibus_hangul_init (IBusBus *bus)
+ g_object_ref_sink (config);
+
+ hangul_keyboard = g_string_new_len ("2", 8);
+- res = ibus_config_get_value (config, "engine/Hangul",
+- "HangulKeyboard", &value);
++ str = NULL;
++ res = config_get_string (config, "engine/Hangul", "HangulKeyboard", &str);
+ if (res) {
+- const gchar* str = g_value_get_string (&value);
+ g_string_assign (hangul_keyboard, str);
+- g_value_unset(&value);
++ g_free (str);
+ }
+
+ hanja_key_list_init(&hanja_keys);
+
+- res = ibus_config_get_value (config, "engine/Hangul",
+- "HanjaKeys", &value);
++ str = NULL;
++ res = config_get_string (config, "engine/Hangul", "HanjaKeys", &str);
+ if (res) {
+- const gchar* str = g_value_get_string (&value);
+ hanja_key_list_set_from_string(&hanja_keys, str);
+- g_value_unset(&value);
++ g_free (str);
+ } else {
+ hanja_key_list_append(&hanja_keys, IBUS_Hangul_Hanja, 0);
+ hanja_key_list_append(&hanja_keys, IBUS_F9, 0);
+@@ -963,27 +970,71 @@ ibus_hangul_engine_property_activate (IBusEngine *engine,
+ }
+ }
+
++static gboolean
++config_get_string (IBusConfig *config,
++ const gchar *section,
++ const gchar *name,
++ gchar **result)
++{
++#if IBUS_CHECK_VERSION(1,3,99)
++ GVariant *value = NULL;
++
++ g_return_val_if_fail (result != NULL, FALSE);
++
++ value = ibus_config_get_value (config, section, name);
++ if (value) {
++ *result = g_strdup (g_variant_get_string (value, NULL));
++ g_variant_unref (value);
++ return TRUE;
++ }
++ return FALSE;
++#else
++ GValue value = { 0 };
++
++ g_return_val_if_fail (result != NULL, FALSE);
++
++ if (ibus_config_get_value (config, section, name, &value)) {
++ *result = g_strdup (g_value_get_string (&value));
++ g_value_unset (&value);
++ return TRUE;
++ }
++ return FALSE;
++#endif /* !IBUS_CHECK_VERSION(1,3,99) */
++}
++
++#if IBUS_CHECK_VERSION(1,3,99)
++#define _g_variant_get_string g_variant_get_string
++#define _g_variant_get_int32 g_variant_get_int32
++#else
++#define _g_variant_get_string(value, length) g_value_get_string(value)
++#define _g_variant_get_int32 g_value_get_int
++#endif /* !IBUS_CHECK_VERSION(1,3,99) */
++
+ static void
+ ibus_config_value_changed (IBusConfig *config,
+ const gchar *section,
+ const gchar *name,
++#if IBUS_CHECK_VERSION(1,3,99)
++ GVariant *value,
++#else
+ GValue *value,
++#endif /* !IBUS_CHECK_VERSION(1,3,99) */
+ gpointer user_data)
+ {
+ IBusHangulEngine *hangul = (IBusHangulEngine *) user_data;
+
+ if (strcmp(section, "engine/Hangul") == 0) {
+ if (strcmp(name, "HangulKeyboard") == 0) {
+- const gchar *str = g_value_get_string (value);
++ const gchar *str = _g_variant_get_string (value, NULL);
+ g_string_assign (hangul_keyboard, str);
+ hangul_ic_select_keyboard (hangul->context, hangul_keyboard->str);
+ } else if (strcmp(name, "HanjaKeys") == 0) {
+- const gchar* str = g_value_get_string (value);
++ const gchar* str = _g_variant_get_string (value, NULL);
+ hanja_key_list_set_from_string(&hanja_keys, str);
+ }
+ } else if (strcmp(section, "panel") == 0) {
+ if (strcmp(name, "lookup_table_orientation") == 0) {
+- lookup_table_orientation = g_value_get_int (value);
++ lookup_table_orientation = _g_variant_get_int32 (value);
+ }
+ }
+ }
+--
+1.7.5.1
+
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild
deleted file mode 100644
index 86ea326759bc..000000000000
--- a/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090328.ebuild,v 1.2 2009/06/18 15:40:05 matsuu Exp $
-
-DESCRIPTION="The Hangul engine for IBus input platform"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND=">=dev-lang/python-2.5
- >=app-i18n/ibus-1.1
- app-i18n/libhangul
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( >=sys-devel/gettext-0.16.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
-}
-
-src_compile() {
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- ewarn "This package is very experimental, please report your bugs to"
- ewarn "http://ibus.googlecode.com/issues/list"
- elog
- elog "You should run ibus-setup and enable IM Engines you want to use!"
- elog
-}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild
index 1cac704cabbb..7bed536ffd76 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild,v 1.5 2011/04/02 02:24:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.2.0.20100102.ebuild,v 1.6 2011/05/25 00:04:59 matsuu Exp $
PYTHON_DEPEND="2:2.5"
inherit python
@@ -16,6 +16,7 @@ IUSE="nls"
RDEPEND=">=dev-lang/python-2.5
>=app-i18n/ibus-1.2
+ !>=app-i18n/ibus-1.3.99
>=app-i18n/libhangul-0.0.10
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.3.0.20100329.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.3.1-r1.ebuild
index b0089ff805db..3784eb3d09bf 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.3.0.20100329.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.3.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.0.20100329.ebuild,v 1.2 2010/04/03 06:03:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.1-r1.ebuild,v 1.1 2011/05/25 00:04:59 matsuu Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2:2.5"
-inherit python
+inherit eutils python
DESCRIPTION="The Hangul engine for IBus input platform"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -16,13 +16,15 @@ KEYWORDS="~amd64 ~x86"
IUSE="nls"
RDEPEND=">=app-i18n/ibus-1.2.99
- >=app-i18n/libhangul-0.0.10
+ >=app-i18n/libhangul-0.0.12
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( >=sys-devel/gettext-0.17 )"
src_prepare() {
+ # http://pkgs.fedoraproject.org/gitweb/?p=ibus-hangul.git
+ epatch "${FILESDIR}/${PN}-ibus-1.4.patch" || die
mv py-compile py-compile.orig || die
ln -s "$(type -P true)" py-compile || die
}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild
index efab0b91d874..c525daed3dfe 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild,v 1.1 2011/04/02 02:24:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.3.1.ebuild,v 1.2 2011/05/25 00:04:59 matsuu Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -16,6 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="nls"
RDEPEND=">=app-i18n/ibus-1.2.99
+ !>=app-i18n/ibus-1.3.99
>=app-i18n/libhangul-0.0.12
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}