summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-23 16:08:11 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-23 16:08:11 +0000
commit91bf08ca856b620d247b6499d00aeec863c61adc (patch)
tree9d4b1596fbe289fa19e30d2ab3e5b73186aa35bb /app-i18n
parentAdded mask for damaged e1000e driver in git-sources (diff)
downloadgentoo-2-91bf08ca856b620d247b6499d00aeec863c61adc.tar.gz
gentoo-2-91bf08ca856b620d247b6499d00aeec863c61adc.tar.bz2
gentoo-2-91bf08ca856b620d247b6499d00aeec863c61adc.zip
Fixed gcc-4.3 issue, bug #238381.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-tomoe/ChangeLog10
-rw-r--r--app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch11
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild29
3 files changed, 48 insertions, 2 deletions
diff --git a/app-i18n/scim-tomoe/ChangeLog b/app-i18n/scim-tomoe/ChangeLog
index 4ad38773c957..bda0c099afec 100644
--- a/app-i18n/scim-tomoe/ChangeLog
+++ b/app-i18n/scim-tomoe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/scim-tomoe
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/ChangeLog,v 1.9 2007/10/14 01:42:53 matsuu Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/ChangeLog,v 1.10 2008/09/23 16:08:11 matsuu Exp $
+
+*scim-tomoe-0.6.0-r1 (23 Sep 2008)
+
+ 23 Sep 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/scim-tomoe-0.6.0-gcc43.patch, +scim-tomoe-0.6.0-r1.ebuild:
+ Fixed gcc-4.3 issue, bug #238381.
14 Oct 2007; <matsuu@gentoo.org> -files/scim-tomoe-0.5.0-gentoo.patch,
-scim-tomoe-0.4.0.ebuild, -scim-tomoe-0.5.0-r1.ebuild,
diff --git a/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch
new file mode 100644
index 000000000000..5464debb0198
--- /dev/null
+++ b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch
@@ -0,0 +1,11 @@
+diff -Naur scim-tomoe-0.6.0.orig/src/scim_tomoe_prefs_widget.cpp scim-tomoe-0.6.0/src/scim_tomoe_prefs_widget.cpp
+--- scim-tomoe-0.6.0.orig/src/scim_tomoe_prefs_widget.cpp 2007-05-07 16:49:15.000000000 +0900
++++ scim-tomoe-0.6.0/src/scim_tomoe_prefs_widget.cpp 2008-09-24 00:57:47.000000000 +0900
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <glib/gi18n-lib.h>
++#include <cstring>
+
+ #include "scim_tomoe_prefs_widget.h"
+ #include "scim_tomoe_prefs.h"
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..798fe3682fe9
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild,v 1.1 2008/09/23 16:08:11 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-i18n/scim-1.2.0
+ >=app-i18n/libtomoe-gtk-0.6.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}