summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-09-30 05:33:32 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-09-30 05:33:32 +0000
commita213f269fe418343de746853bd4df81f488877ba (patch)
tree545442d10f2d48618e5f2d7db9a46a7c55ff7001 /app-i18n
parentNew upstream version. (diff)
downloadgentoo-2-a213f269fe418343de746853bd4df81f488877ba.tar.gz
gentoo-2-a213f269fe418343de746853bd4df81f488877ba.tar.bz2
gentoo-2-a213f269fe418343de746853bd4df81f488877ba.zip
Fixed fails to build with USE="gtk -canna -anthy", Bug 149132.
(Portage version: 2.1.1)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/uim/ChangeLog5
-rw-r--r--app-i18n/uim/uim-1.2.1.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/app-i18n/uim/ChangeLog b/app-i18n/uim/ChangeLog
index 23499524fc8c..1681b63c55c1 100644
--- a/app-i18n/uim/ChangeLog
+++ b/app-i18n/uim/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-i18n/uim
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.138 2006/09/24 07:26:25 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.139 2006/09/30 05:33:32 matsuu Exp $
+
+ 30 Sep 2006; MATSUU Takuto <matsuu@gentoo.org> uim-1.2.1.ebuild:
+ Fixed fails to build with USE="gtk -canna -anthy", Bug 149132.
*uim-1.2.1 (24 Sep 2006)
diff --git a/app-i18n/uim/uim-1.2.1.ebuild b/app-i18n/uim/uim-1.2.1.ebuild
index ab18e246b8d2..34fe6437d46c 100644
--- a/app-i18n/uim/uim-1.2.1.ebuild
+++ b/app-i18n/uim/uim-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.2.1.ebuild,v 1.1 2006/09/24 07:26:25 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.2.1.ebuild,v 1.2 2006/09/30 05:33:32 matsuu Exp $
inherit eutils kde-functions flag-o-matic multilib elisp-common
@@ -58,6 +58,14 @@ pkg_setup() {
}
src_compile() {
+ local myconf
+
+ if use gtk && (use anthy || use canna); then
+ myconf="${myconf} --enable-dict"
+ else
+ myconf="${myconf} --disable-dict"
+ fi
+
econf $(use_with X x) \
$(use_with anthy) \
$(use_with canna) \
@@ -65,12 +73,12 @@ src_compile() {
$(use_enable emacs) \
$(use_with gnome panel) \
$(use_with gtk gtk2) \
- $(use_enable gtk dict) \
$(use_with libedit) \
$(use_with m17n-lib m17nlib) \
$(use_enable nls) \
$(use_with qt3 qt) \
- $(use_with qt3 qt-immodule) || die "econf failed"
+ $(use_with qt3 qt-immodule) \
+ ${myconf} || die "econf failed"
emake -j1 || die "emake failed"
}
@@ -83,9 +91,7 @@ src_install() {
pkg_postinst() {
einfo
- einfo "To use uim-anthy you should emerge app-i18n/anthy or app-i18n/anthy-ss."
einfo "To use uim-skk you should emerge app-i18n/skk-jisyo."
- einfo "To use uim-prime you should emerge app-i18n/prime."
einfo
ewarn