summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-08-01 16:58:02 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-08-01 16:58:02 +0000
commita989de6abf4171c426c6b12d1ef0f7e6b2676a42 (patch)
tree9163881503be5fbbd8e6d6b683c60632f76b0113 /app-i18n
parentStable on amd64 wrt bug #330729 (diff)
downloadgentoo-2-a989de6abf4171c426c6b12d1ef0f7e6b2676a42.tar.gz
gentoo-2-a989de6abf4171c426c6b12d1ef0f7e6b2676a42.tar.bz2
gentoo-2-a989de6abf4171c426c6b12d1ef0f7e6b2676a42.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-pinyin/ChangeLog7
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.3.9.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-i18n/ibus-pinyin/ChangeLog b/app-i18n/ibus-pinyin/ChangeLog
index ec74123b7842..02fef56da46f 100644
--- a/app-i18n/ibus-pinyin/ChangeLog
+++ b/app-i18n/ibus-pinyin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-pinyin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.25 2010/05/29 16:51:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.26 2010/08/01 16:58:02 matsuu Exp $
+
+*ibus-pinyin-1.3.9 (01 Aug 2010)
+
+ 01 Aug 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-pinyin-1.3.9.ebuild:
+ Version bumped.
*ibus-pinyin-1.3.8 (29 May 2010)
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.3.9.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.9.ebuild
new file mode 100644
index 000000000000..4d49117e9068
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ibus-pinyin-1.3.9.ebuild,v 1.1 2010/08/01 16:58:02 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit python
+
+PYDB_TAR="pinyin-database-1.2.99.tar.bz2"
+DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ http://ibus.googlecode.com/files/${PYDB_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ >=dev-libs/boost-1.39
+ sys-apps/util-linux
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ cp "${DISTDIR}/${PYDB_TAR}" "${S}"/data/db/open-phrase/ || die
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) --enable-db-open-phrase || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}