summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-09-01 10:54:20 +0000
committerBen de Groot <yngwin@gentoo.org>2012-09-01 10:54:20 +0000
commitb564b8b2067a6ef9eba4f2bb4a3dbe024f3264c6 (patch)
tree04e1f6ca2dba2c9c8c7109b9e2c9be982cc685d9 /app-i18n
parentInitial commit. Ebuild from gentoo-zh overlay, polished by dlan and me. (diff)
downloadgentoo-2-b564b8b2067a6ef9eba4f2bb4a3dbe024f3264c6.tar.gz
gentoo-2-b564b8b2067a6ef9eba4f2bb4a3dbe024f3264c6.tar.bz2
gentoo-2-b564b8b2067a6ef9eba4f2bb4a3dbe024f3264c6.zip
Initial commit. Ebuild from gentoo-zh overlay, polished by dlan and me.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-rime/ChangeLog9
-rw-r--r--app-i18n/ibus-rime/Manifest3
-rw-r--r--app-i18n/ibus-rime/ibus-rime-0.9.2.ebuild29
-rw-r--r--app-i18n/ibus-rime/metadata.xml18
4 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/ibus-rime/ChangeLog b/app-i18n/ibus-rime/ChangeLog
new file mode 100644
index 000000000000..1f67b10a3fa9
--- /dev/null
+++ b/app-i18n/ibus-rime/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-i18n/ibus-rime
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-rime/ChangeLog,v 1.1 2012/09/01 10:54:20 yngwin Exp $
+
+*ibus-rime-0.9.2 (01 Sep 2012)
+
+ 01 Sep 2012; Ben de Groot <yngwin@gentoo.org> +ibus-rime-0.9.2.ebuild,
+ +metadata.xml:
+ Initial commit. Ebuild from gentoo-zh overlay, polished by dlan and me.
diff --git a/app-i18n/ibus-rime/Manifest b/app-i18n/ibus-rime/Manifest
new file mode 100644
index 000000000000..ca4dda1651f0
--- /dev/null
+++ b/app-i18n/ibus-rime/Manifest
@@ -0,0 +1,3 @@
+DIST ibus-rime-0.9.2.tar.gz 23400 SHA256 204c00498293d1a1c28d785c540e57001cb92aa99d43806a2970afd100f1bcca SHA512 40405783f87f46d3a5a681c912869786686a276709d4b41f91f4df915951d7bc82ee6e907f2da346fcfb20c412fe7ccfc2fc50cfac507206b7b1fada67b826f7 WHIRLPOOL 21bb1f73a8dad7245c4f8848ab15232e5542ec837d8d76b3a0c1a1b2a934c152dd06a0366048dd2c8be282f1ae364142c610158b9528cba28607fd9d5a79e611
+EBUILD ibus-rime-0.9.2.ebuild 689 SHA256 abbeced2a79a16df65d716b1186adee09065ab4121c10e6f1b69db71cc27de84 SHA512 1e9b4c07ab70d2c2aa9ac4bdd966446dcf6377546286460773c4b13c1f54629f63b5c757494dd906e7173b21fefb075104c62fcadae77702e03c3b8ad10255f3 WHIRLPOOL 00df693f4ea6272bebae7909cd221b0968ba6d65fb724fc49768c4d3426c306315ea0d71778247488ed7092a93d8cdf48a01dc0e2f43a0d7e90892ff861f0013
+MISC metadata.xml 550 SHA256 920e86b29ced653a5668fe43874ecb7b5488a7250794946c50a8807c7e1d04d4 SHA512 e051bdb788af3b12bb7ce24c748c5feb062fe8e4ef758e8145c3796ba102448ae0f4b066e8e41f80edec2f7a7e6104acf403d517d32de7affde108e18855f81a WHIRLPOOL 6900820e584c25ec8235ccd25056714a42c7740ffb5f75080713e305bfb3ca38fcc7bd915c228ace8a860ff585c7372d28ba66a60ed46463ead35330d6b1b5b3
diff --git a/app-i18n/ibus-rime/ibus-rime-0.9.2.ebuild b/app-i18n/ibus-rime/ibus-rime-0.9.2.ebuild
new file mode 100644
index 000000000000..9444c0fcf8f6
--- /dev/null
+++ b/app-i18n/ibus-rime/ibus-rime-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-rime/ibus-rime-0.9.2.ebuild,v 1.1 2012/09/01 10:54:20 yngwin Exp $
+
+EAPI=4
+
+inherit vcs-snapshot
+
+DESCRIPTION="Rime Input Method Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/rimeime/"
+SRC_URI="https://github.com/lotem/${PN}/tarball/rime-${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-i18n/ibus
+ app-i18n/librime
+ x11-libs/libnotify"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
+ app-i18n/rime-data"
+
+src_prepare() {
+ sed -i -e "/libexecdir/s:/usr/lib:/usr/libexec:" Makefile || die
+ sed -i -e "/exec/s:/usr/lib:/usr/libexec:" rime.xml || die
+}
diff --git a/app-i18n/ibus-rime/metadata.xml b/app-i18n/ibus-rime/metadata.xml
new file mode 100644
index 000000000000..b0c809c038eb
--- /dev/null
+++ b/app-i18n/ibus-rime/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>dennis.yxun@gmail.com</email>
+ <name>Lan Yixun (dlan)</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>chen.sst@gmail.com</email>
+ <name>Gong Chen</name>
+ </maintainer>
+ <bugs-to>http://code.google.com/p/rimeime/issues/list</bugs-to>
+ <remote-id type="google-code">rimeime</remote-id>
+ </upstream>
+</pkgmetadata>