summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-04-13 23:05:35 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-04-13 23:05:35 +0000
commitba96ff39ad94b22fce2bddbe646c35f11416957e (patch)
treefb2fb17ec1a1b96988f0d31873bbd4d2207864e6 /app-i18n
parentAdd patch to allow compile with <gcc-4.1.2. (diff)
downloadgentoo-2-ba96ff39ad94b22fce2bddbe646c35f11416957e.tar.gz
gentoo-2-ba96ff39ad94b22fce2bddbe646c35f11416957e.tar.bz2
gentoo-2-ba96ff39ad94b22fce2bddbe646c35f11416957e.zip
Fixed to work with recent fribidi, bug #264281.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/bidiv/ChangeLog10
-rw-r--r--app-i18n/bidiv/bidiv-1.5-r1.ebuild36
-rw-r--r--app-i18n/bidiv/files/bidiv-1.5-fribidi.patch39
3 files changed, 83 insertions, 2 deletions
diff --git a/app-i18n/bidiv/ChangeLog b/app-i18n/bidiv/ChangeLog
index 13354511f714..b69d0a38189d 100644
--- a/app-i18n/bidiv/ChangeLog
+++ b/app-i18n/bidiv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/bidiv
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/bidiv/ChangeLog,v 1.11 2007/05/08 16:16:12 drac Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/bidiv/ChangeLog,v 1.12 2009/04/13 23:05:35 matsuu Exp $
+
+*bidiv-1.5-r1 (13 Apr 2009)
+
+ 13 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/bidiv-1.5-fribidi.patch, +bidiv-1.5-r1.ebuild:
+ Fixed to work with recent fribidi, bug #264281.
*bidiv-1.5 (08 May 2007)
diff --git a/app-i18n/bidiv/bidiv-1.5-r1.ebuild b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
new file mode 100644
index 000000000000..b07ac9e40d09
--- /dev/null
+++ b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/bidiv/bidiv-1.5-r1.ebuild,v 1.1 2009/04/13 23:05:35 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A BiDirectional Text Viewer"
+HOMEPAGE="http://www.ivrix.org.il"
+SRC_URI="http://ftp.ivrix.org.il/pub/ivrix/src/cmdline/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/fribidi"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fribidi.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CC_OPT_FLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin bidiv
+ dodoc README WHATSNEW
+ doman bidiv.1
+}
diff --git a/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch b/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch
new file mode 100644
index 000000000000..0671a0e57b26
--- /dev/null
+++ b/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch
@@ -0,0 +1,39 @@
+diff -Naur bidiv.orig/Makefile bidiv/Makefile
+--- bidiv.orig/Makefile 2006-01-08 03:45:11.000000000 +0900
++++ bidiv/Makefile 2009-04-13 17:55:23.000000000 +0900
+@@ -4,8 +4,8 @@
+ CC_OPT_FLAGS=-O2 -Wall
+
+
+-CFLAGS= $(CC_OPT_FLAGS) $(DEFS) `fribidi-config --cflags`
+-LDFLAGS=`fribidi-config --libs`
++CFLAGS= $(CC_OPT_FLAGS) $(DEFS) `pkg-config fribidi --cflags`
++LDFLAGS=`pkg-config fribidi --libs`
+
+ all: bidiv
+
+diff -Naur bidiv.orig/bidiv.c bidiv/bidiv.c
+--- bidiv.orig/bidiv.c 2006-01-08 04:05:54.000000000 +0900
++++ bidiv/bidiv.c 2009-04-13 17:55:23.000000000 +0900
+@@ -172,7 +172,7 @@
+ }
+ #ifndef TRY_UTF8
+ in[len]='\0';
+- fribidi_iso8859_8_to_unicode(in, unicode_in);
++ fribidi_charset_to_unicode(FRIBIDI_CHAR_SET_ISO8859_8, in, unicode_in);
+ #endif
+
+ /* output the line */
+@@ -201,10 +201,10 @@
+ rtl_line=0;
+
+ if(out_utf8)
+- fribidi_unicode_to_utf8(unicode_out, len,
++ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8, unicode_out, len,
+ out);
+ else
+- fribidi_unicode_to_iso8859_8(unicode_out, len,
++ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_ISO8859_8, unicode_out, len,
+ out);
+ /* if rtl_line (i.e., base_dir is RL), and we didn't fill the
+ entire width, we need to pad with spaces. Maybe in the