summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-05-13 23:19:02 +0000
committerBen de Groot <yngwin@gentoo.org>2009-05-13 23:19:02 +0000
commite97068227776b60f267d41080981aba5c2c0e7ce (patch)
treeb80ee3b57243ec646971c10a809a0875e2db8331 /app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild
parentVersion bump (#269393). (diff)
downloadgentoo-2-e97068227776b60f267d41080981aba5c2c0e7ce.tar.gz
gentoo-2-e97068227776b60f267d41080981aba5c2c0e7ce.tar.bz2
gentoo-2-e97068227776b60f267d41080981aba5c2c0e7ce.zip
Initial import. Ebuild by Daniel Klaffenbach in bug 262051.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild')
-rw-r--r--app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild b/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild
new file mode 100644
index 000000000000..b577d9dc3c25
--- /dev/null
+++ b/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-9999.ebuild,v 1.1 2009/05/13 23:19:02 yngwin Exp $
+
+inherit eutils git linux-mod
+
+DESCRIPTION="Linux kernel support for the Lenovo SL series ThinkPads"
+HOMEPAGE="http://github.com/tetromino/lenovo-sl-laptop"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+EGIT_REPO_URI="git://github.com/tetromino/lenovo-sl-laptop.git"
+EGIT_BRANCH="master"
+
+CONFIG_CHECK="HWMON BACKLIGHT_CLASS_DEVICE"
+MODULE_NAMES="${PN}(acpi)"
+BUILD_TARGETS="module"
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}