summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-09-15 08:08:40 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-09-15 08:08:40 +0000
commitc6ac381b62e1baf50ed0c45576d52342e2806fa9 (patch)
treed3f166580fa12e832ad8d1e30a9b8b6d0cadacf4 /app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild
parentBug #62280 add ttf support. Bug #63981 add debug support. (diff)
downloadgentoo-2-c6ac381b62e1baf50ed0c45576d52342e2806fa9.tar.gz
gentoo-2-c6ac381b62e1baf50ed0c45576d52342e2806fa9.tar.bz2
gentoo-2-c6ac381b62e1baf50ed0c45576d52342e2806fa9.zip
New version
Diffstat (limited to 'app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild')
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild
new file mode 100644
index 000000000000..bef34de7739b
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.6.5.ebuild,v 1.1 2004/09/15 08:08:40 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="program to map special Powerbook/iBook keys"
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/baselayout-1.8.6.12-r1"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-compat.patch
+}
+
+src_compile() {
+ econf || die "sorry, failed to configure pbbuttonsd"
+ make || die "sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "This version of pbbuttonsd can replace PMUD functionality."
+ einfo "If you want PMUD installed and running, you should set"
+ einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
+ einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
+ einfo "disabling PMUD"
+}