summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-07-02 13:43:40 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-07-02 13:43:40 +0000
commit56ff816e5cf08635339b98aa26fbe905623a6239 (patch)
treec5e465a6913c247649d78fc5f352f968774904a1 /app-laptop/pbbuttonsd
parentAdjusted metadata, see bug #138062. (diff)
downloadgentoo-2-56ff816e5cf08635339b98aa26fbe905623a6239.tar.gz
gentoo-2-56ff816e5cf08635339b98aa26fbe905623a6239.tar.bz2
gentoo-2-56ff816e5cf08635339b98aa26fbe905623a6239.zip
Version bump. This version provides 255 levels for the keyboard illumination and a smoother fade. The ALSA segfault should be resolved.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog8
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.63
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.6.ebuild74
3 files changed, 84 insertions, 1 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index ea0fe49a8fc9..80e7b8c01199 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.49 2006/06/06 17:15:28 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.50 2006/07/02 13:43:40 chainsaw Exp $
+
+*pbbuttonsd-0.7.6 (02 Jul 2006)
+
+ 02 Jul 2006; Tony Vroon <chainsaw@gentoo.org> +pbbuttonsd-0.7.6.ebuild:
+ Version bump. This version provides 255 levels for the keyboard illumination
+ and a smoother fade. The ALSA segfault should be resolved.
06 Jun 2006; Luca Barbato <lu_zero@gentoo.org> pbbuttonsd-0.7.5.ebuild:
Added missing dir as pointed in bug #135698
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.6 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.6
new file mode 100644
index 000000000000..a73f65433053
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.6
@@ -0,0 +1,3 @@
+MD5 886012c195f2adc3cda952db6ece0b01 pbbuttonsd-0.7.6.tar.gz 450244
+RMD160 c8f2bcef37f4eed00c5b01f549cb0b2f3e78db9f pbbuttonsd-0.7.6.tar.gz 450244
+SHA256 a40a1f149565ed0a2955d07898f6519bb76a5db36f155134d6bd58112ca839cf pbbuttonsd-0.7.6.tar.gz 450244
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.6.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.6.ebuild
new file mode 100644
index 000000000000..14ba4978ca4f
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.6.ebuild,v 1.1 2006/07/02 13:43:40 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+IUSE="acpi debug alsa oss ibam"
+
+DEPEND=">=sys-apps/baselayout-1.8.6.12-r1
+ >=dev-libs/glib-2.6"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use x86; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_with debug) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+ emake || die "Sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ einfo
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.conf to limit access."
+ einfo
+
+ if use ppc ; then
+ einfo "It's recommended that you let pbbuttonsd act as the low level"
+ einfo "power manager instead of using pmud."
+ einfo
+ fi
+ if use ibam; then
+ einfo "To properly initialize the IBaM battery database, you will"
+ einfo "need to perform a full discharge/charge cycle. For more"
+ einfo "details, please see the pbbuttonsd man page."
+ einfo
+ fi
+ ewarn "Warning: the NoTapTyping option is unstable, see bug #86768."
+}