summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-07-31 20:33:26 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-07-31 20:33:26 +0000
commita8bcee02acc90c93eef1f81b3d29995552ab2954 (patch)
treef064b7b05039849cd44a30ebdd175431b70b6f91 /app-laptop/pbbuttonsd
parentInitial commit for vmware-server-console. (diff)
downloadgentoo-2-a8bcee02acc90c93eef1f81b3d29995552ab2954.tar.gz
gentoo-2-a8bcee02acc90c93eef1f81b3d29995552ab2954.tar.bz2
gentoo-2-a8bcee02acc90c93eef1f81b3d29995552ab2954.zip
Latest release, includes workaround for the synaptics trackpad blocking issue.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.83
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild74
3 files changed, 83 insertions, 1 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 80e7b8c01199..e58ecc442ac2 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.50 2006/07/02 13:43:40 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.51 2006/07/31 20:33:26 josejx Exp $
+
+*pbbuttonsd-0.7.8 (31 Jul 2006)
+
+ 31 Jul 2006; Joseph Jezak <josejx@gentoo.org> +pbbuttonsd-0.7.8.ebuild:
+ Latest release, includes workaround for the synaptics trackpad blocking issue.
*pbbuttonsd-0.7.6 (02 Jul 2006)
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.8 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.8
new file mode 100644
index 000000000000..ed3d9a9f7efd
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.8
@@ -0,0 +1,3 @@
+MD5 139f2f15028faabef30408f2db87c973 pbbuttonsd-0.7.8.tar.gz 425183
+RMD160 d8e9e792df8e6cd8a3867c3bdd4bcbb1955e90f1 pbbuttonsd-0.7.8.tar.gz 425183
+SHA256 a8e9d7722c05d7f4cc2137d1853411be7b1e42366c72b8bfe6c06ed81f92aee4 pbbuttonsd-0.7.8.tar.gz 425183
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild
new file mode 100644
index 000000000000..812487ba472b
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.8.ebuild,v 1.1 2006/07/31 20:33:26 josejx Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+IUSE="acpi debug alsa oss ibam"
+
+DEPEND=">=sys-apps/baselayout-1.8.6.12-r1
+ >=dev-libs/glib-2.6"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use x86; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_with debug) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+ emake || die "Sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ einfo
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.conf to limit access."
+ einfo
+
+ if use ppc ; then
+ einfo "It's recommended that you let pbbuttonsd act as the low level"
+ einfo "power manager instead of using pmud."
+ einfo
+ fi
+ if use ibam; then
+ einfo "To properly initialize the IBaM battery database, you will"
+ einfo "need to perform a full discharge/charge cycle. For more"
+ einfo "details, please see the pbbuttonsd man page."
+ einfo
+ fi
+ ewarn "Warning: the NoTapTyping option is unstable, see bug #86768."
+}