summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
commit0ba2da8c1d8edaed3fd1b059f3dc80b334d89314 (patch)
treeb4720eadae9333815ae7989d9d8c4b55da9b4f8f /app-laptop/thinkpad/thinkpad-4.3.ebuild
parentAdded ~mips. Fixed CXXFLAGS so that non-x86 builds work. QA: added IUSE. (Man... (diff)
downloadgentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.tar.gz
gentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.tar.bz2
gentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-laptop/thinkpad/thinkpad-4.3.ebuild')
-rw-r--r--app-laptop/thinkpad/thinkpad-4.3.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-laptop/thinkpad/thinkpad-4.3.ebuild b/app-laptop/thinkpad/thinkpad-4.3.ebuild
index ddf3e6e86862..49c397a4db14 100644
--- a/app-laptop/thinkpad/thinkpad-4.3.ebuild
+++ b/app-laptop/thinkpad/thinkpad-4.3.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-4.3.ebuild,v 1.3 2004/06/24 22:00:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-4.3.ebuild,v 1.4 2004/06/28 02:37:18 vapier Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control kernel modules"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="x86 amd64 -ppc -mips -sparc"
-IUSE=""
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
-#virtual/glibc should depend on specific kernel headers
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
check_KV
@@ -37,7 +37,7 @@ src_compile() {
}
src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TECHNOTES
dodir /lib/modules/${KV}/thinkpad
cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
${D}/lib/modules/${KV}/thinkpad
@@ -50,7 +50,7 @@ src_install() {
}
pkg_postinst() {
- /usr/sbin/update-modules || return 0
+ [ "${ROOT}" == "/" ] && /usr/sbin/update-modules
if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
ewarn 'Your /etc/devfsd.conf is missing the include for'
ewarn '/etc/devfs.d/! Please fix this by adding'
@@ -63,7 +63,3 @@ pkg_postinst() {
ewarn '/etc/devfsd.conf if you like.'
fi
}
-
-pkg_prerm() {
- /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
-}