summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-10-20 08:35:22 +0000
committerPeter Weller <welp@gentoo.org>2008-10-20 08:35:22 +0000
commit8f04f3b41200d412cfd5b4c6add68e581e35732c (patch)
treeec83c5b3963ba3c71338a7395859b3076a0443db /app-laptop/tp_smapi/tp_smapi-0.39.ebuild
parentalpha stable wrt security #242702 (diff)
downloadgentoo-2-8f04f3b41200d412cfd5b4c6add68e581e35732c.tar.gz
gentoo-2-8f04f3b41200d412cfd5b4c6add68e581e35732c.tar.bz2
gentoo-2-8f04f3b41200d412cfd5b4c6add68e581e35732c.zip
Bump to 0.39; Bug 239033
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoomarx x86_64)
Diffstat (limited to 'app-laptop/tp_smapi/tp_smapi-0.39.ebuild')
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.39.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-laptop/tp_smapi/tp_smapi-0.39.ebuild b/app-laptop/tp_smapi/tp_smapi-0.39.ebuild
new file mode 100644
index 000000000000..7d156fc6ca25
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.39.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.39.ebuild,v 1.1 2008/10/20 08:35:22 welp Exp $
+
+inherit linux-mod linux-info
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 19; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.19 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+
+ CONFIG_CHECK="!SENSORS_HDAPS"
+ ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
+ linux-info_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove usage of `sudo` in Makefile.
+ sed -i 's,sudo ,,' Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}