summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-10-23 17:38:00 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-10-23 17:38:00 +0000
commitd017af0af3afcee36e22d0aca56daf604b515874 (patch)
treeba0710d449da1293eb3e8b131de0ff1ab3a8172f /app-laptop/tpb/tpb-0.6.4.ebuild
parentRev bump. Clean up ebuild. Remove old versions (diff)
downloadgentoo-2-d017af0af3afcee36e22d0aca56daf604b515874.tar.gz
gentoo-2-d017af0af3afcee36e22d0aca56daf604b515874.tar.bz2
gentoo-2-d017af0af3afcee36e22d0aca56daf604b515874.zip
Version bump, bug #108159.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-laptop/tpb/tpb-0.6.4.ebuild')
-rw-r--r--app-laptop/tpb/tpb-0.6.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-laptop/tpb/tpb-0.6.4.ebuild b/app-laptop/tpb/tpb-0.6.4.ebuild
new file mode 100644
index 000000000000..5b764aee8254
--- /dev/null
+++ b/app-laptop/tpb/tpb-0.6.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.6.4.ebuild,v 1.1 2005/10/23 17:38:00 brix Exp $
+
+inherit linux-info eutils
+
+DESCRIPTION="IBM ThinkPad buttons utility"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
+SRC_URI="http://savannah.nongnu.org/download/tpb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc"
+
+IUSE="nls xosd"
+
+DEPEND="virtual/x11
+ xosd? ( >=x11-libs/xosd-2.2.0 )"
+
+CONFIG_CHECK="~NVRAM"
+ERROR_NVRAM="${P} requires /dev/nvram support (CONFIG_NVRAM)"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-configure-fix.diff
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xosd) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc README ChangeLog CREDITS TODO
+ dodoc doc/{callback_example.sh,nvram.txt,tpbrc}
+}